Adding Telemetry to the Walkera QR X350 Pro

multirotor

#62

I bought a different radio for telemetry. Would I need to change any resistors?


#64

As the Author of the wiring diagram (on this site and from RCgroups) for the Devo-M with OSD and Wireless Telemetry , I can say that it is not wrong,
Im the guy that first came up with the idea of adding the OSD to the Devo-M and to supply the first wiring diagram to show how , (I didnt do the resistor mod’s) and had a degree of success ,showing voltage, flight mode and position
The RX and TX on the Devo-M board are switched around ,
If you are using an APM board then it should be RX on the APM to TX on the OSD and wireless Telemetry
But as the RX and TX are switched around on the Devo-M,
So It is RX on the Devo-M to RX on the OSD and RX on Devo-M to RX on the wireless Telemetry, those who have done the OSD mode can confirm this,
I would like to add I have fried my Devo-M board after a crash( my fault I didnt do the props up enough) lol, so I am unable to test any further mods,
I am going to rebuild the QRX 350 Pro with the APM 2.6 or 2.7 with external GPS and compass with wireless telemetry ,


#65

Hi All,

tried a lot and finally it´s working…
my setup: QR X350 Pro with 3DR V2.

What I did was, first switched the 2 resistors like mentioned above.
second I wired the TX to the RX and RX to TX on the DEVO-M and not like in the first picture.
Now start-up the QR X350 normally and open MP.
At this point the green led on the 3DR V2 should be solid green.
Go to the Com-port selection in MP and select Com # Arduino 2560 and hit Ctrl+t , do not press the connect button.
Now You should see Your parameters working, disconnect by pressing the button in MP and again go to the COM-port
selecion and select the COM# of the 3DR. Now only hit Ctrl+t and the parameters in MP should be alive again.
Now you can remove the USB cable from the drone and everything is working.
Remember to always hit Ctrl+t to start the connection and never do it with the ´connect´ button.

Hope this helps others… if there are questions, let me know but in this way it works for me…


#66

Hi Golem 777. I’m glad for your successful experience. I also was able to pass the telemetry with precisely that technique with the USB port and after disconnect and hit Ctrl+T, without changing the resistors (read above). The only problem is that we could not change anything or send commands to the Drone. Can you please test if you really have full duplex connection? A simple test is trying to read the Full Parameter list from the drone with only the wireless connection (without full duplex it’s not happening). If you are successful in reading this list try to change any parameter and write (after you can reverse). Change, for instance, CH7 behaviour (it will not be harmful and you can reverse it). Try also to do a planning and upload it to the Drone via 3DR radio. Best Regards and thank you for sharing your experience!


#67

Yeaaaa it works. Telemetry works with tx to tx and rx to rx. I dont know if duplex works from following some if these instructions by many but first by grandpa… it works.
Oh important thing is I DIDNT CHANGE ANY RESISTORS!


#68

Hi Berta,

Did some tests and and can´t upload by ´air´ . only see actual data coming in by ´air´.
So I don´t have full duplex I think… Still happy with it but have to wait until a solution
is found to have full-duplex with the V2. I changed the resistors so That´s not the trick
for the V2 if You have the same result without changing the resistors…


#69

Hi Golem777. That’s what I was afraid of. We still have to wait for a full duplex connection. I’m already happy with the telemetry transmitted by “air” and I can obtain it perfectly with the 3DR V2 radios without changing any resistor, using the technique you described. An upload connection can be very important in some missions, for instance if you want to alter the mission plan while the quad is in the air. Sometimes for things so simple as avoid a tree in the path which we were only aware when the mission is ongoing. But there are lots of other important things that can be done with upload capability. And we could spare the need of a USB connection to the computer. However having the echo of all the Drone activity is already very very useful. I’m doing photogrammetry missions using this technique and a auto-triggered Canon with CHDK.


#70

any update on this guys? I just bought all the V1 stuff and want to get OSD up and running. Really wanted to get follow me feature working primarily. :smile:


#71

Hey all, I have been watching this forum for a while now and struggle with the same issues, but I want full duplex so bad…
then we essentially turn our x350 pro into a scout x4 :slight_smile: and on the scout they use that monster of a bluetooth downlink that goes for over 500 bux.
I am only using v1 china telemetry but was wondering what happens when one connects the v2 3dr setup directly into the usb port on the copter? does it power up when you connect the battery? wouldnt that be the same as connecting the cable straight to the pc? because I am sure if one was to have a long enough cable you could take off with it and upload way points so why would it be different?
I am wondering where we loose the interpretation… could it be loosing too many packets or inconsistency?


#72

Hi unmannedtech, Is there any progress with telemetry on QR X350 Pro ?


#73

Come on guys . Does any of you have managed to solve the problem with the telemetry? Unmannedtech has forgotten us clearly :frowning:


#74

I can confirm changing the 0ohm resistor with a 1k resistor WORKS! The 0ohm resistor is the one next to the MEGA chip. Not the one by the TX and RX pads. If that one is changed to around 470-670ohm then telemetry may work with USB plugged in. I have FULL duplex telemetry working on the Devo-M. The only drawback at the moment is USB will not work unless you unplug the telemetry module. We believe changing the other resistor will make this work. The job is not easy as it will require excellent soldering skills with a fine point soldering iron and a magnifying glass held by a 3rd arm. Also a bright light over the work area.

EDIT: After adding a 1k ohm normal sized resistor between the TX pad on the Devo-M and the TX wire going to the telemetry module - The USB works with the telemetry still connected.

This works folks. I have done Follow Me mode and that works also with the Devo-M!


#75

Dronetech is that all you did? No other resistors ? Rx to rx and tx to tx and you got it ?


#76

YES!! I have full duplex telemetry and USB working. Replace the resistor next to the MEGA32U2 chip with a 1k and that gets telemetry up and running but then you add a 1k legged, normal size resistor between the TX pad and the wire going to the telemetry. That makes it easier to do the mod. When you add the 1k resistor at the TX pad that makes USB work. Without that resistor USB will not connect. Also if you have trouble soldering all you have to do is crush the 0 ohm resistor next to the MEGA32U2 chip. That will open the circuit and telemetry will work but you will have NO USB! You must add the 1k ohm resistor at both locations I mentioned above to get both the telemetry radio and USB to work side by side. The only thing I did different was just add the normal sized, legged 1k resistor at the TX pad in series between the TX wire of the telemetry. You can leave the resistor circled in red that says to change it to 680 ohms there. Don’t change it. Adding a legged resistor between the TX pad TX telemetry wire works.


#77

UnmannedTech’s directions are right but instead of changing the resistor next to the TX pad I just added a 1k to the TX pad directly between the TX wire from the telemetry and the TX pad on the Devo-M.


#78

please, how to with pictures. tks


#79

The how to is already here on this page. The only thing I did different was to add a hole through resistor at the TX pad between the TX wire going to the telemetry. Everything else above is correct. I’m sorry but I’ve already put the Devo-M back together and installed it. I wont be able to get pictures. But like I said - the directions above will work. Thats confirmed.


#80

One other thing. If you want telemetry working both ways all you have to do is crush the 0ohm resistor next to the MEGA32U2 chip in the pictures above on this page. Make sure it is OPEN. That resistor is the reason why telemetry comms are CLOSED. Walkera closed looped the comms between the 2560 and the MEGA with that resistor. But! With an open circuit there at the 0ohm resistor USB will not work until you close that circuit. You could crush the resistor for telemetry to work and when you want to upgrade firmware just put a blob of solder where the 0ohm resistor was to close the circuit. That would require hardly any soldering. At least then you wouldn’t have to solder the very small resistors in place.


#81

So caught my DEVO-M, welding wires and just crush the resistor?


#82

Had anyone tried reprogramm the bootloader on the mega 2560 ?
I mean - re -flash the bootloader via ICSP and AVR programmer, using original
APM bootloader rather than DEVO M.

Hence we later can try to install APM arducopter 3.2 firmware !

Anybody ?

Thanks in advance …