Unmanned Mini pixhawk -- No motor output

pixhawk

#1

I have just received my pixmini from unmannedtechshop.co.uk

Firmware installed no problem. Compass, gps ect are calibrated and working fine. The quad arms but when i put the throttle up only the motor connected to the pin S2 starts. All the other ESCs keep beeping that they are getting no signal. To me it seem like there is a hardware fault on the other signal pins. I have connected each esc to the pin S2 in turn and given them throttle to check all the escs and motors are working.

Either i have a faulty board or the pinouts from the micro have changed in the firmware.

Help – Has anyone had the same problem??


#2

That does sound like it could be a hardware problem. And good to hear you did some troubleshooting to confirm the problems are not with your ESC.

However before sending it back for replacement, can you give me some details on what version of arducopter you are using. Also did you load any parameter setting files onto the board after installing firmware? Lastly could you just try loading arduplane firmware to see if any of the other motor outputs work?

But it does sound like you have done some testing yourself so if it is indeed faulty send us an email with your order number and we will organise to replace it for you.


#3

The firmware is adrucopter 3.2.1
I also tried the octocopter firmware so that i could check each of the signal pins. Only S2 and S6 are giving out any signal.
I am currently trying to get Arduplane to arm. Will let you know how i get on but i really think i had a faulty board


#4

Sorry FW 3.1.2
Arduplane was unsuccessfull. I also tried using Arducopter 3.0.1 but again only signal pin S2 was functional. I might just post it back tomorrow if I can find an address for returns.

I am also struggling to get the 433 telemetry work as there are no instructions for it.
I had very high hopes but I have had nothing but disappointment today


#5

Thanks for trying a few more things but it does sound like something is not right so please send support an email with your order number and include a link to this thread and we will send you return details.


#6

Ok thank you. I have sent an email to the returns/shipping department. Will i need to return the power module as i have it soldered onto my power dist board and i would rather leave it there

Thanks for your help


#7

Thanks,it should be fine to just return the autopilot module itself instead of all the other parts, unless you feel there is any issues with them. .

Thanks for sending the email so we can get the returns process started, but not really a shipping/returns department, we are still a very small business so all of us wear many hats! However we will get your issue resolved as fast as possible. :wrench: so you can get back in the air.


#8

Good evening,

So now i have got my quad copter up and running which is great. Gps functions work well and i did not need to do any tuning to get out flying, loitering and RTL. The problem is I just cannot get the 433 telemetry to work. The dongle that plugs into my pc is lighting up and seems to be working correctly. Comes up as silicon labs bridge in the terminal com port list which is fine. The module that gets plugged into my autopilot does nothing. I have it plugged into the port above telemetry 1. Is this the correct port for it to be connected to? There are no instructions at all for this autopilot.


#9

Happy to hear that you made some progress with your quadcopter! :sparkles:

As for the telemetry, could you possible send a photo showing it connected? Do you get any LED’s when it is plugged in?


#10

I do not get any leds lighting up when i connect the module to the autopilot.


The quad was powered by battery in this photo

I have it connected to telem1 with the ground on the outside to the left.Is that the correct port?


#11

If you are not getting any LED on the telemetry module then that would suggest that it is not powered correctly. It does look like it is connected correctly on the autopilot. Do you have a multi-meter available to try check the cables to see if it is producing 5V output between the black and red wires?


#12

Good Morning.Yes i have checked and i am getting 5v out the pixhawk and all the way to the telem module. I removed the case for the module so i could check the pinouts. I buzzed out the silver pads marked vcc gnd rx tx to the jst pins on the module. it seems to me like the cable i was provided had the ground and Vcc the wrong way round which means that the minute i connected the module it was shorted out. I have fixed the cable but the module is dead. No leds but it does heat up which tells me it is faulty. Would it be possible to get a new module sent out?


#13

Sorry about the delays in getting back to you, but sure I will arrange to get a replacement unit sent to you first thing tomorrow as it does sound like the module is not working.