TBS unify pro race HV audio with this FC?

vtx
fpv

#1

You guys have helped a lot so far, i’m a newbie and just figuring out as i go!
i have runcam owl plus connected to this board and have a TBS unify pro race hv ready to install;

https://www.unmannedtechshop.co.uk/streak-f4-v3-168mhz-flight-controller-with-osd/

I can’t see where to solder the audio? does this FC board even support audio? AND the board has 5v 12v regulator for fpv equipment, so do i only need signal, grnd and 5v out?


#2

The board doesn’t need the audio that travels through your video transmitter (vtx) and then you just plug headphones into ur goggles if the mic is installed on cam
Perry


#3

I know this is a Runcam swift 2 but you may have same


#4

hmm, interesting. The Owl Plus doesn’t look to have a mic? atleast externally. I’ve had a quick google but i’ll look more into it tomorrow.
Thanks again, mate.


#5

Do you mean to use the smart audio feature of the Unify? If so you need to solder the cable to a TX in one of the available UARTs of your FC. If you only mean to install the vtx and don’t care about smart audio then yeah, plugging 5v, gnd and signal will be enough


#6

Correct the owl does not have a MIC output so you can just ignore that, and as @Twistem said, if your camera does have a mic you just wire that directly to audio in on your VTX (if supported) . Some VTX might have a built in Mic so nothing to connect, but generally its rare nowadays.


#7

ok Alex,
I think i’m getting there?! and i will post a pic of my drone very shortly. As long as you don’t laugh.
I am using your streak f4 flight controller and i’m now struggling with the OSD.

WARNING: this is my first build and this is a brand new hobby for me - so take it easy with me! I’ve had some very good advice on here so far, and it’s been invaluable
The description of the board states built in OSD and i can see from the schematic diagram there is somewhere for an OSD to be wired to the FC, but when i switch on my fatsharks, i do have some osd? it says ‘disarmed/no data’ ‘0.0v’ ‘acre’ and a timer. I can arm the quad from my radio transmitter (turnigy evolution) but it changes nothing on my ‘OSD’? being an unmannedtechshop expert - can you help me? i can’t find a lot on youtube with this set up i’m using.


#8

Sounds like you just need to enable msp data on the correct UART port. I can’t recall which UART port the issue is connected to off hand (I think it’s uart1) but if that is not working, I would suggest tlyou try them each one at a time. Also make sure the baud rate is 115200.

Also have you tried to upload new firmware onto the v3, as right now I don’t suggest you do that as there is still no official target for this board yet


#9

@Graham_Cassidy I’m sure this goes in line with what I said in the other post