T-Motor 4-in-1 45A - BlHeli32 can't connect to one ESC


#1

Hello all.

I’m having issues with a brand new T-Motor 4-in-1 45A. I currently have it connected to an Airbot Omnibus F4 Nano V6 Flight Controller and I cant seem to connect to the Motor physically labelled motor 4.

When I load up the BlHeli_32 Suite I am able to connect to the other 3 ESCs, however, ESC number 4 always comes up UNKNOWN. Here’s what I’ve tried:

-Flashing the FC with the latest firmware
-Changing the motor resource on the FC to all of the other ports (while the ident in BlHeli_32 changes the same phyical motor will not connect)
-changing the 4-in-1 cable to another cable (both brand new)
-changing the protocol (Dshot1200, Dshot600 etc)
-trying 3 different computers to connect BlHeli_32 suite

My thinking is that there is either a bad pin on the M4 wire or ESC-4 is toast. Does anyone out there have a suggestion as to where I can buzz (with a multimeter) the 4-in-1 and the FC to prove that the pins are OK? Or does anyone have any better ideas?

I really want solid evidence that the 4-in-1 is toast before I send it back T-Motor.

Thanks in advance.


#2

you either have a bad connection on the signal wire for that ESC.
or its got corrupted firmware on it.

So

Check your wiring, and try a re flash


#3

So I fixed it.
Here’s a little bit of feedback for anyone out there with a similar issue.

It was suggested to me that I test the connection from the FC to the 4-in-1 with an Oscilloscope. At first I thought this would be a redundant test as I could buzz continuity between the boards.
However, while the resistance was low enough to allow me to buzz from the 4-in-1 to the FC, the impedance was obviously high enough to stop an AC signal. After putting a scope on the boards it all became so clear. I had a recessed pin on the 4-in-1. A little bit of doctoring and problem solved.

The will be one dude out there in 5 years time with the same problem and this will be the only page on the internet that will hopefully help. :stuck_out_tongue_winking_eye:


closed #4

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.