Omnibus F3 AIO + iNav... AETR5678 instead of AETR1234 channels?

omnibus
inav

#1

I got the Omnibus F3 AIO board and flashed it with INAV 1.7.3. In the GUI, I set the receiver type to to PPM. However, in the Receiver tab, the default setting shows AETR5678 (not 1234). I am using a FlySky FS-i6s radio and AETR are fixed to channels 1234.

I flashed the same board with Cleanflight and it showed AETR1234. I also had used INav with a SP Racinh F3 board and there two it showed AETR1234. It is only the combination of Omnibus F3 with INAV that is producing AETR5678.

Any clue? How can I get inav with Omnibus to have AETR1234.


#2

Hi
I think you are misinterpreting the meaning of this in th GUI
AETR5678 means that channels 1 to 4, which are the usual joystick channels are mapped to AETR and the 5678 means that the remaining auxiliary channels are mapped to channels 5,6,7&8 and onward if you have a TX/RX more than 8 channels

the snap below is from my Omnibus F3, iNav 1.7.3 default settings

BUT what I am puzzling over is why the colour bar representation has throttle at 4 and yaw (rudder) at 3 :confused: :confused:

However if you look in CLI dump you’ll see that it maps these 4 channels as AETR1234 which I think is the confirmation you are looking for that all is as you want it

’ # map
’ map AETR1234

HTH
Cheers
Steve :slight_smile:


#3

Hi Stephen,

Thank you for your feedback.

You explanation makes sense (and clarifies things to me) but it solves half the problem. The other unsolved issue is that the channels in the GUI (in the receiver tab) do not react to the stick movements. I am using a PPM receiver and already set the receiver type to “PPM” in the Configuration tab (my understanding is that this is all that is required foe stting up a PPM receiver, i.e. no need to physically remove the Sbus bridge/transistor on the FC board).

Any clue as to what I am missing here.


#4

Hi
Do you have anything else on UART3? If so that is probably the problem as PPM requires use of UART3
If not, check the 0R links to the left of the PPM Pin, maybe your board was not set correctly at the factory
If not already done so, have a look a this sites guide for this FC


I’ll try to find time tomorrow to power up my board in PPM and see if I get the same problems
Cheers
Steve🙂


#5

Just a quick thought…
Have you used the receiver before?
If new could it not be paired to the TX?
Cheers
Steve :slightly_smiling_face:


#6

Hi Steve,

The issue is definitely not the receiver. I’ve used it many times with the same transmitter, even with the same Omnibus board but with Cleanflight and Betaflight. The problem happens with this FC when running iNAV.

Nothing running in UART3


#7

Hi,
I connected mine up this morning and Yes, I have the same issue.

I connected only:-
LiPo, set at 11.4v (3S)
PPM, 3 wires, checked 5v present, RX LED on and sending battery voltage back to TX so all OK there

RX choice in iNav is PPM, no movement in Receiver tab colour bars when sticks moved
I’ll investigate further tonight
Cheers Steve :slight_smile:


#8

Hi again
I couldn’t leave this alone :cold_sweat:
A bit of 'net research suggests we have to remove the tiny 0R link in the SBUS position
Can’t wait to get home and try it :grin:
Cheers
Steve :slight_smile:


#9

Steve,

You’ve just described my case exactly. That’s what I experienced.

Unfortunately, yesterday I lost my Omnibus board. I connected my GPS to see if it works with the board. 2 seconds after connecting my 3s Lipo I got the magic smoke. Don’t know why.

I will wait for you trial to see if I get a new Omnibus board or use a different one like the SP Racing F4 EVO.

Thanks


#10

Hi,
Sorry to hear about your board
When bench testing new stuff instead of using a LiPo I power off a variable DC supply with current limit set at a few hundred milliamperes higher than I’m expecting the board to take, then when I do something stupid (often :weary:) the board is saved
Sorry if this sounds like advice too late
I’ll post again when I’ve played tonight
Cheers
Steve :slightly_smiling_face:


#11

It’s absolutely ok, I consider this loss part of the learning experience :grinning:

Important thing is to resolve the issue with Omnibus +iNAV.


#12

Hi

Before changing any links I plugged in a sbus receiver, enable uart3 as Serial RX in ports, selected SBUS receiver and set serialrx_provider as SBUS.
It did not work either :sob:

Removed SBUS 0R link (leaving the PPM one in place), back to the PPM receiver and still not work either :sob: :sob: BUT after trying various options I got it working with these settings

            YES, No Receiver !!!

Sticks bottom right

Sticks top left

Changes to TX sticks needed to get correct channel movements



Although this worked I’ll not be trusting it in flight.
The forums do talk about some workarounds which I’ll try later.

QUOTE
"(0) Full erase flash latest FC firmware (1) Connect, goto configuration tab, select RX_SERIAL, save and reboot. (2) Connect, goto ports tab, turn on SerialRX on UART3, save and reboot Sounds like Serial RX configuration, right? (3) Connect, goto configuration tab, verify RX_PPM has revived. (4) Goto receiver tab and see your PPM receiver working!!!"

There appears to be a later version of iNav,1.8.0 which I’ll try. The release notes show changes to receiver configuration and selecting so maybe this has been resolved.

Need to leave it now, will carry on in the morning
Cheers
Steve :slight_smile:


#13

Thanks again Steve. Seems like a complicated way fro a simple task!


#14

Hi
Still no joy with PPM :unamused:
But as the same receiver supports ibus I tried that and all works nicely:grin:

The SBUS 0R link is in place, the PPM one is removed.

Note UART3 set to serial RX

I’ve done a little video, trying to upload it, watch this space !!

I’m going to leave this post now (my intention for my board is Futaba SBUS, this problem just intrigued me)
I’ll keep an eye out for any new releases of iNav for PPM
Has anybody else on the forum experienced and solved this?

Cheers
Steve :slight_smile:


#15

thanks that is the answer ive looked for im using uart 3 for gps cheers mate