Ominbus F4 V4 & DYS XSD 20A ESC - DSHOT not working


#1

I am using the latest firmware for the ESC’s and Omnibus flight controller and the latest Betaflight configurator. I have connected the controller to VBAT, connected just one ESC to VBAT and ESC data connection to the controller.

I can control the motor from Betaflight when in oneshot or multishot mode but in any Dshot mode the fight controller locks up after a few seconds. I can use BLheli in passthrough when the flight controller is in oneshot or multishot mode but not in Dshot (because the fight controller is locked up or it has lost the serial connection for some reason).

Has anyone experienced this or have any suggestions?

Many thanks


#2

Do you have the newest bf? There was/is a bug with Dshot and older build of BF 3.2.


#3

Hi

Thanks for your reply. I have Betaflight configurator 3.1.1. Is this not the latest one?

Regards
Dom


#4

Depends on your BF firmware Version on your Flightcontroler.

Try “version” on cli and see what it says.

The configurator version 3.1.1 is the latest stable version. For betaflight 3.2 you need 3.1.2.


#5

Hi

I now have the 3.1.2 configurator installed.

My current version is Betaflight / OMNIBUSF4SD 3.1.7 Apr 3 2017 / 22:15:40 (e1c4b5c)

I now need to work out how to get veriosn 3.2 firmware and see if it makes a difference

Thanks
Dom


#6

I have now worked out how to flash the board with 3.2

version

Betaflight / OMNIBUSF4SD 3.2.0 Jul 21 2017 / 09:39:28 (9ee4ba4)

It didn’t solve the problem though :frowning:

Regards


#7

Alright. Well, did you also flash your escs with the correct dshot firmware?


#8

I checked the version on the DYS XSD 20A ESC’s and it was 16.6 which appears to be the latest version so I didn’t update it.


#9

Are you using the Search card logging on the board? If so can you try disable it and see if you have any issues as it might be a SD card bug due to DMA mode causing an issue.

Its a longshot, but worth a try


#10

I am not using logging and no SD card installed. I just have power applied (VBAT) and one ESC. Maybe I will try another ESC just incase one has an issue. I have found that the problem is not just with Dshot. The flight controller locks up on oneshot or multishot too but just takes a little longer. Maybe I have a defective ESC or flight controller.

Dom


#11

Hmm that is abit strange, and the lock up occurs even when the FC is powered via battery and you are not using betaflight? Just checking so we k ow of its maybe betaflight software locking up, rather than the firmware.

If you still have issues with another ESC, and also when not connected to betaflight then maybe the Baird is faulty so we will need to investigate that further and replace the FC


#12

Thanks for your help. I found out what the problem is. It must be the USB drivers on my laptop as when I tried another laptop it works just fine. On the other laptop I let Windows pick the driver and it works. On my laptop I used Impules RC to select the driver but that was causing a problem. I also tried Zagdig but I still couldn’t find a driver that works. Any idea which driver I need to install for Windows 7? The laptop that it works OK on is Windows 10.

Regards

Dom