Omnibus F4 V2 Bricked on first flash


#1

I just finished putting together my Omnibus F4 V2 flight controller. Connected up via beta flight and tried to flash the board up to 3.1.5. As soon as the erasing step started the buzzer started screaming and the flashing failed to complete. I have disconnected the USB and tried booting to DFU mode (boot button pressed when power connected) but the board just screams! I have desoldered the buzzer and the RAM to 5v link and disconnected all other connections and I still get the same thing. Is the board bricked? or can anyone suggest what I can do now.

Thanks,
Adam


#2

Just in case anyone asks, I was able to connect beta flight to the FC with it’s original firmware (3.0.5 I think). So the board was working before trying to flash it.


#3

Whuch target did you select when flashing the firmware? As I know there are two for the omnibus boards, can’t recall off hand what they are called exactly, but since the v2 has an SD card slot you need to select the omnibusf4SD target.

Hope that helps!


#4

Thanks for the suggestion. Unfortunately it won’t boot into DFU mode! Do you know how I can get it back into DFU mode?


#5

I assume you are pressing the boot button when applying power to your FC?


#6

Yes, I am pressing the ‘boot’ button when applying power. I have also tested the boot button with a continuity tester and the button is working. I have also applied power via a 5v regulator as well as the USB and no difference!


#7

Hello Alex,

Thank you for your help. It sounds like I have a dead Omnibus F4 V2 flight controller. I have about 20 flight controllers and I always thought they they were un-brickable. Is this a quirk of the new F4 processor, or Omnibus, or do I just have a faulty board?

Thanks,
Adam


#8

Okay, so they are unbrickable! It appears that when the problem happened it took down part of the USB stack on my Mac. After rebooting the Mac I was able to get the board back into DFU mode and flash the chip. Very strange, because it’s a Mac I very rarely reboot and it hadn’t even crossed my mind.

Alex, thanks for your input.


#9

Happy to hear you got it working, and they are not completely unbrickable but under normal use they dont usually get bricked.


#10

I am having a similar issue, except with a windows computer. I have flashed quite a few F3 boards without issue recently. I went to flash my Omnibus f4 v2. I originally got into DFU mode no problem, I loaded the latest AIRBOTF4 betaflight target and went to flash. It got all the way to the point of erasing, but while it is doing that I get a pop up in the log line that says “read protection not active”. It would then hang on ‘erasing’ and then I’d get another log line that says "usb device successfully closed."
I tried updating my drivers and that just made it worse. Now I can’t connect to the flight controller at all - not in DFU mode or normally.
I may have to go to system restore now and undo what I did to my laptop! I have a feeling that I only made my driver situation worse(windows 10, btw).


#11

I had a very similar issue. Using a F4 V5Pro that uses the Omnibus F4 firmware. I went to flash it and the second it started erasing the buzzer began going non-stop and it hung while flashing. After I unplugged it I couldn’t get it to show up even in DFU mode.

Had all but given up when I found if I powered it through a battery while holding the boot button then plugged in usb it would show up. I then found it would erase but would still hang during flashing. Eventually found that turning off full chip erase let it flash correctly.