Not Showing OSD in walksnail goggles

Order Number: 694674
Product Name: Caddxfpv Gofilm 20 Cinewhoop W/ Walksnail Moonlight 4k / C0ca-Fp010
Brand: Caddx
When connected to WS avatar goggles, the gofilm WILL provide video however Won’t provide OSD data from the FC, e.g battery voltage, etc.

I have tried everything i can find to solve the problem however nothing is working.
I have found when using debug mode in the goggles the FC is failing to be recognised which is what has lead me to believe it may actually be faulty and not just user error.
I have ensured OSD feature is enabled on the other features tab.

I have updated made sure that the ports are correct, (the VTX being UART1), and that its running the correct protocol, (VTX (MSP + Displayport)

On the OSD tab of BF, HD format is selected with OSD elements on all 3 profiles just in case.

I have tried different BF presets for setting up HD video.

I have tried all the above using the CLI commands instead of UI buttons.

I have updated all Walksnail firmware to the latest, however the moonlight VTX came with the latest preinstalled. Then tried it all again.

Although prebuilt, I have checked that the Rx/Tx to Tx/Rx is correct.

I looked at the debug screen in the goggles while the VTX is connected and under the section stating FC it is blank, stating “FC : —” which is not the case on my other walksnail drones.

Using the Walksnail OSD tool for adding back the OSD data to videos after the fact the OSD tool fails to recognise the FC firmware stating it as “Unknown” however there is a small amount of data in the “.osd” file however im not sure if this is just always present. Just a few KB.

I have not tried to reflash betaflight onto the AIO/FC as 1, its not possible as it cant access the bootloader, 2, reflashing BnF quads isnt advisable.

I do not want to disassemble anything without contacting you first.

Thank you for your time.
Rob.

Just to close the loop on this should anyone else have a similar issue. we have been talking with @roblynds and Caddx, and it looks like the Moonlight VTX unit is faulty so this is being replaced.

So if anyone else has this issue its best to reach out to Caddx support and they should be able to confirm the issue and arrange a replacement (if ordered from us, they will ask you to return the faulty unit to us, and we will send you a replacement).