Issues with Betaflight

wizardx220
betaflight

#1

Hey all,

I had some issues with my quad this evening.
I have an Eachine Wizard X220 that has only been out for a few flights but has experienced a few crashes as well. This evening when adjusting my rates, I wanted to test the arming as I enabled the idle motor spin when the quad is armed, so (yes, I know I did a bad thing and I learned my lesson the hard way) I put on the props and set it on the ground, powered it on and flicked the arming switch. It seemed fine so I gave it a little throttle and then backed off to 0. However, the quad didn’t. I quickly disarmed the quad, but yet again, it didn’t. Instead, it increased the throttle and even remained armed when I powered off the remote. In fact, it throttled so high that it lifted off and then spiraled and crashed, destroying all 4 props (two of them hit me but I’m alright).

With the threat of the props gone, I plugged it into my computer and opened betaflight. There didn’t seem to be anything wrong with my config except for the fact that receiver tab did not show anything. (See pics: https://drive.google.com/open?id=0Bz7gw_c3GS-ETGswQnRseElDaG8) Nothing has changed since my last flight except for the fact that I adjusted my rates and the idling motor when armed. I even turned the idling off and still was experiencing receiver issues.

When I power on the quad by batter with the remote on, the remote connects to the quad no problem, but it wont arm. When the battery is in and connected to betaflight, it doesn’t show that it’s receiving any inputs.

I’m at a loss. I reset the quad, reset the remote, verified that all my wire connects were solid on the quad and that everything was the way I had it during my last successful flight. The receiver on the quad is receiving power but it just isn’t sending signals to the board.

I would really appreciate any help anyone could provide.

Thank you


#2

Sorry to hear about the issue, but at least you are ok, and that your quad is still relatively ok.

The issue you have with the receiver tab not having any bars, and the bars not moving is something that we have been noticing quite often the last week, so maybe there is some weird betaflight bug that we dont know about yet… But for some reason some flight controllers reset the RC stick min center and max values to zero:

If you set them back to normal which should be 1000, 1500, 2000 you should find the stick inputs will be detected again.

Also I suggest you set the arm function to be a switch on your remote as that way you know for sure if its armed or not. And also I suggest you setup the failsafe so if you do turn of your radio the motors will cut out, as this can save you from a flyaway quad.

Let me know if that solves your problem :slight_smile:


#3

I made the change and it didn’t seem to do much, but it did make a difference.


Here’s the new screen

Two things I’ve noticed that are continuing:

  1. When I power on the radio, it makes its startup beeps and then waits for a signal from the quad. I’ll then plug in the battery to the quad and the instant the battery is connected, the radio makes a lower pitched beep than the startup beeps. Not sure what it means. I’m using the FS-i6.

  2. Every now and then when plugged into betaflight, despite sitting on a level surface, the display of the quad’s orientation will twitch and end up in a position that the quad is not in.

For reference, I had switch A on my quad set to the arming switch and I had a failsafe set as well. Any ideas as to why the quad didn’t respond to either?

I have a sneaking suspicion that something shorted out and I may need a new flight controller :confused:

Thank you for your help


#4

here is something to try…

raise the stick minimum to 5 units about the actual stick minimum when your throttle is all the way down. For example…if you push your throttle down and you see 1000 then set your stick min to 1005.

Once you do that and save, see if you can arm.


#5

When this happened to me Betaflight also reset the failsafe setting to zero. You need to be in expert mode in Betaflight to check this on the Failsafe page. I reset Betaflight to default to solve my issue but it turned out that the servo and Failsafe settings were the only issues.