Iris+ flips over at take off


#1

Hi

Just unpacked and assembled an Iris+, followed all instructions, green light, armed, motors fired up.
Then took throttle past half way point to take off and flipped over onto its back.
Tried again with more throttle and same thing.
Any suggestions before I run of and start playing with ESC calibrations etc.

Thanks


#2

Hi

My suggestion would be to first check that all the props are connected the the correct motors and that they are not upside down (the writing on the propellers should be facing upwards)

When you arm your IRIS do all the motors spin at the same time and as the same speed? If not then it can be due to an ESC calibration issue, in which case you can follow this video:

I would also double check that nothing it catching your IRIS+ when its taking off (like long grass) as that can also cause it to flip on takeoff.

.Hope you have a great Christmas! :christmas_tree: :santa:


#3

Thanks for that.

Verified that props on correct way so performed ESC calibration but was not initially able to do this without putting the throttle trim to full up.

Performed a calibration of radio and then ESC calibration successful.
Then tried a test without props to see what happened.

Powered up to half throttle, OK, added more throttle and no change in motor noise, no change from half throttle up to full throttle. I was also unable to DISARM by moving joystick to bottom left.

Went back to ESC calibration as this is directly to ESC and full power at full throttle so all OK here.

I am also unable to connect via the telemetry radio using mission planner or droid planner but can direct to the USB.


#4

If your motors don’t seems to be spinning according to the throttle setting on your stick (assuming you are in stabilised mode) then there is an issue with ESC or radio calibration. Have you tried to go through the radio calibration screen again?

As for the fact that you can’t connect via telemetry, have you set the correct baud rate in mission planner? For the 3DR radio modules this should be set to 57600 and with direct USB its 115200