Brand new IRIS+ wont Arm


#1

Hi, I cannot arm my IRIS+ so have not even had a 1st flight 8-((
I follow the instructions but get flashing yellow lights after the initialisation sequence.

I am a total newbie but I thought I was capable of turning it on!

I have followed the instructions I have found online so far but nothing has fixed it as yet.

I did connect using Mission Controller and the virtual controls
move when I move them on the transmitter so it must be seeing the
transmitter.
I also reset the parameters from the Iris+ Param file through
Mission controller and that seemed to load OK with a reboot of the Iris+
at the end but still no joy.

Help please!


#2

Hi

Sorry to hear that you are having a problem with the IRIS+. By the sounds of it you cant get it to arm as its failing the pre-arm safety checks. Are you trying to do this indoors?

My suggestion would be to connect via the radios on missing planner and then try to arm your quadopter, if there are any issues you will see the problem on the HUD display, this video should help -

Also have you looked at the IRIS+ getting started videos

If you have any other questions please let me know