Getting S6 to work on unmanned mini hawk (pixmini)

plane
pixhawk

#1

Hi, I’m using a mini unmanned hawk purchased from yourselves as part of a university project.

Our design is a flying wing with two separate elevators. I managed to program our radio transmitter to set s2 and s4 on the main out rail to control the two elevators, but the ailerons have been set to channels 1 and 6. S1 works fine but when I plug a servo into s6 I dont get a physical output. Mission planner shows that the radio 6 channel is getting a signal but it isn’t pushing it through to the servo.

The servo is getting power as when I arm the autopilot it moves into the neutral position, and I tested the same servo in s1 where it worked. So for some reason the autopilot isn’t sending a signal to s6, any idea how I can correct this? I can’t change the channel on the radio transmitter from 6, it is factory set.


#2

Sorry to hear about that, have you tried to enable PWM pass-through to S6 to check that works? Also have you tried using the servo tester feature in mission planner to see it is actually sending a signal out?


#3

Thanks Alex, I had to turn on the RC Function for RC_6, you were right. However, what I have now noticed is that servo 6 rotates much more than the servos in 1, 2 and 4. Any idea why this might be? And also how I could get 1, 2 and 4 to move as much as servo 6?


#4

You will need to check the servo range setting, the PWM max/min range… cant recall the mission planner parameter for this off hand as I have not played with arduplane code for a couple months now.

Hope that helps :slight_smile: