FY Mini 3D Pro Iris+ pixhawk setup


#1

Hi

I am struggling to get the gimbal to tilt to point at a Region Of Interest during auto missions built using Tower, DroidPlanner 2 and Mission Planner.
So far I have managed to set up the gimbal and Pixhawk to be able to control camera tilt via TX channel six dial, camera pan via TX channel 8 dial and gimbal mode via TX channel 7 switch.
After hours of tinkering with parms and web searching I am still to find a solution.
So far I have updated the gimbal firmware, rolled back pixhawk firmware from AC3.3.3 to 3.2, changed CH6 pwm max and min ranges to 1000 and 2000, toggled RC6 and RC9 FUNCTION and reversed the tilt servo. During tests using the ‘point camera here’ option in Mission Planner I have seen the gimball point down for a split second and then return to pointing straight ahead.

Has anyone successfully installed the FY Mini 3D Pro and enabled control during auto missions?


#2

Do you know if you have loaded the firmware with rocker position mode, or rocker speed mode? You will need to sure the position mode so that your pixhawk can send it absolute position so it knows what angle to point to.


#3

Hi Alex. I updated the gimbal with the rocker position mode firmware.
After looking at somebody else’s params and trying a few diferent things out I have worked out that my original setup did not like having the gimbal mode switching from CH7 on TX and CH11 on PIX with CH11 function set to MNT_ROLL.
I have tried setting to different functions (eg camera trigger and landing gear) to see if they would work without affecting ‘auto tilt’, but was unsuccessful. I did get the gimbal to point and stay pointed down using ‘point camera here’ in MP after disabling the CH11 function.
So, I thought, I would be able to set ROI in auto missions by forfeiting being able to switch gimbal modes, sorted!
However I took the quad out to test ealier today and the gimbal pointed the camera straight down rather than at the ROI. This happened during and auto mission I had configured and when I used ‘Dronie’. I also tested ‘follow me’ which appeared to control the gimbal but failed to keep me in frame (although this could be down to the short ‘leash’ distance I had set (5m)).
I will try some more testing later using DroidPlanner2 instead of Tower as someone has mentioned before that ROI may not work well in Tower.

In the meantime do you know of any other channel functions that I could use instead of MNT_ROLL that would replicate the gimbal mode switching?