Cleanflight Taranis settings for FrSky RX

taranis

#1

My new Taranis plus is bound to the receiver, but nothing moves in Cleanflight when I move the sticks on the transmitter.

I have UART 2 set to Serial RX; and RX Serial and S-BUS selected on the Receiver page. (I have tried a few other combinations in desperation, but think this is right for my receiver, which is a FrSky XSR 2.4GHz 16ch)

I’ve tried holding the throttle stick at bottom right position to arm (which is the default arm setting?) but still nothing happens with the Throttle, Ail, Ele and Rudder graphics bars in Cleanflight.

I’ve also tried to set up an arm switch, but again, this doesn’t activate the receiver settings in Cleanflight. Nor does the switch position register on the Modes page.

The drone is also beeping constantly, which after several hours is really beginning to wind me up!

I’m sure I’m doing something simple wrong… any help very gratefully received!


#2

Did you set up in the Modes tab in Cleanflight? And what FC are you using and how did you wire the receiver in?


#3

The first thing you probably want to do while trying to figuure this out is to disable the buzzer, this can be done by either putting some tape on it, or disable the voltage alarm on the config page of cleanflight.

Am I correct to assume that once you are in the receiver tab, nothing is moving when taranis is turned on?

As for the issue, did you purchase the taranis/receiver from us? As most EU shops have taranis and receiver with the LBT firmware which is not compatible with the international firmware. And are you certain they are abound?

Secondly, can you try to connect PPM to your flight controller and enable PPM as the receiver type to see if that works?


#4

no, i have not setup modes tab as i do not know how to do it properly thanks for the reply


#5

sorry for my reply ignore it sorry :slight_smile: