Cleanflight + FlySky IA6 Aux channel issue

Im having simular problem if we were to get the IAB we might not have the problem using Sbus maybe. It also has somethimg to do with that switches assign menu. Its a right mess. I need to save for a Taranis i cant work it out i cant assign the different modes and arming. Ive managed to get one aux working in clean flight but its only letting me use thr VGA knob thing. Just no good. vexxed.

You have one working?! I’ve not managed to get any working so far. I’m gunna spend an hour later trying to solve it but so far I’ve not found anything. No solid answers online, just people saying what Alex has above.

The radio and RX are advertised as 6 channels and should work, should be no need to get the IA6B just for that. As much as it would solve the issue, that’s not the point :frowning:

I’ve got an FS-i6 transmitter with an IA6b receiver working all six channels on a NAZE board using Cleanflight, It all set up quickly as it should so not aware of these problems.
Tomorrow I’ll post snaps of TX screen and Cleanflight, hopefully this will help.
Steve :slight_smile:

The IA6 and IA6B are different.

IA6B has PPM, IA6 is PWM. I’m using the IA6. Still curious to see yours if you’re set up in PWM though.

Ahhh good point. I’m using PPM
If it helps I can move it onto PWM and see how it behaves
Steve :slight_smile:

Make sure your switches even work, you can test that by booting your fs-i6 into a different mode by putting both sticks down and left and turning it on. Go to buttons test (or something like that) and see if those switches and aux channels work.

Stevietee10 - That’d be great, but I don’t want to risk breaking yours! Let’s see if there’s an answer first.

RobbieGM - I know for sure the switches work. The Nighthawk’s channel leads are not clearly marked, so I had to play a game of plug-in-this-one-and-see. So accidentally plugging Ch5 into Aileron, it would show up in Cleanflight when I moved the switch. Even if I change the leads around so AERT are plugged into Ch5 and Ch6, the Aux channels don’t move in Cleanflight, but the AERT will continue to move with the switches.If that makes sense. Starting to think the RX might be faulty…

Could you send a screenshot of your receiver config within cleanflight, and also a photo/diagram of how your IA6 is connected as it is indeed strange that its not picking up the aux channels since you have set it up correctly on your frsky radio. Since you are using IA6, I assume you have connected everything via PWM, so one wire per channel?

Also have you enabled softserial at all within cleanflight?

Worst case if we cant get this resolved over the forums you can always send it to me to have a look and get it all working for you.

Update: Also I just remembered we had a customer with a similar issue of some channels not working and it turned out that some of the pins on the nighthawk connector where bent so that might be something worth checking!

Yes, PWM. One wire per channel.

Cleanflight Reciever settings:

Connection look like this: (crude paint diagram

I’ve looked and my softserial was off, tried turning it on and playing with the ports, still didn’t show the aux channels. Turned it back off. Checked the pins and they all seem fine. Double checked connection and they all look good too. Going to continue to try find the answer tonight/tomorrow as I have some time off work. As far as sending it to you, I live pretty close to your shop as it is, so if push comes to shove, I could always pop by and get it looked at then.

Thanks for the pics, could you also send a screenshot of your receiver tab where you see the bars move according to stick inputs? As that should show you what each channel is mapped to and you can also alter the mapping there.

Receiver tab:

I tried changing channel mapping around too and still hasn’t shown any Aux channel movement. I’ve played some more with the TX (as it’s new) and found more Aux settings which I’ve played with and it still hasn’t changed anything. Even tried hooking up the older TX I have but they wouldn’t connect so couldn’t see if there was an issue there.

Have you re-done stick calibration, including moving switches as well as sticks ?
Steve :slight_smile:

I don’t think it’s a calibration issue as the Aux switches will activate channels when they’re plugged into AETR. If they were calibrated wrong, surely they wouldn’t move the channel at all? And vise versa, when an AETR channel is plugged into an Aux channel, they won’t move at all where as they have full 1000-2000 control in their correct channels.

When I look on the “display” function on the TX, I can see the switches moving from 1000-2000, just not on Cleanflight.

That is very strange, so when you connect one of your AUX channels to input 1-4 on your flight controller then the switches move correctly within cleanflight as Roll/Pitch/Yaw/Throttle? Or have you not tried that?

Yup, that exactly. AETR(1,2,3,4) always move, Aux 1 and 2 have never moved. Regardless of what is plugged into them.

Has anyone figured out this issue and how to fix it?

Yeah, buy an ia6b and use PPM.

On a serious note; I never found a solution. I did pick up a few ia6b units and they just worked with no issues including switches. No idea what was going on.

I have the same freaking problem. Have been trying everything to figure this out. I can’t not get it to work in betaflight st all

Hi, re. my post of the 16 Nov

I’m out of the country now until 22nd Dec.
When back I’ll set this configuration up on the bench and see if I can bottom it out.
Sorry can’t get to it any sooner, hotel rooms in India aren’t as well equipped as my workshop :laughing: :laughing:
Steve :slight_smile:

Hey, Im new to this and i had the same problem with my Fly Sky Tx and my Rx Tgy ia6 (yes they work together). I had the exact same reaction, but only one aux was working (cable yellow) but the other cable wasnt ( this on a F3 SP FC). What i did was checking the connections of the cables to the FC, and it turns out my yellow cable wasnt in all the way!! Just put back in and TADAAA i have the 2 aux working. Hope this helps!!!