Changes in CLI for different PID profiles


#1

I have 3 PID profiles. I am trying to change my I term relax cut off to 11 . I term type to GYRO .
I have Bettaflight 4.0.2 flashed to my 239 NX Rabbit. Im in expert mode I type profile 0 for 1 profile 1 for profile 2 type profile 2 for 3. For what ever profile I’m changing.
I then enter my changes in the CLI . They go up on the CLI screen properly with no error coming up . I hit save after I’ve double checked there entered correctly .
Then I check that the changes were accepted and they have not. I have tried this several times with no changes to my profiles.
Can someone please tell me what I’m missing ?
I’m woundering maybe it didn’t take the settings because I didn’t have I term relax button on at the time I tried to make the changes in the CLI line ?


#2

@Lowkater420 You say “hit save” after making the changes - are you clicking the save button or typing “save” and then enter?


#3

I’m sorry I meant type save and then hit enter.
I’m talking with Joshua bardwell on messenger about it I sent him a video.
I’m beginning to wonder if maybe I need to reflash my flight controller?


#4

Let me know if you get to the bottom of it - I do know there were some issues around PID profiles that were fixed in 4.0.3 but I think they were related to copying profiles… If not you could try raising an issue on the betaflight github.


#5

Joshua Bardwell helped me out. It was a beginner mistake on my part.
I was putting hash # before the word set.
So betaflight was just ignoring my change.
Example on what I was typing in the CLI:

set Iterm_relax_cutoff= 11

I should have just put : set iterm_relax_cutoff=11
Without the hash #
How do I go about marking my problem as solution solved in dronetrest ?


#6

How do I mark this problem solved ?


#7

Joshua Bardwell helped me out.