Can't connect Vortex blade to BetaFlight please help!


#1

I know very little about BetaFlight. I watched and learned as much as I could. I downloaded BetaFlight and the two drivers that go with it. Next I connected my Vortex quadcopter to BetaFlight and clicked on Connect. It says connection failed. I am at a complete loss as what to try next. Do I push in the button on the back of the Vortex? Thank you.

Mike


#2

Which vortex are you using? As some of them need to use immersionRC’s own updater to load the latest firmware onto it before you can hook it up to betaflight.

However if you have one of the more recent vortex quads, then it should connect to betaflight and its porbably that you have the wrong driver installed… I found the best thing to do is to use the impulserc driver fixer as it will automaticly find what driver you need, I discuss this in the guide below:

Hope that helps :slight_smile:


#3

Hi,

I am using the Vortex Blade which I just purchased it in October of 2017. Yes, I probably am using the wrong driver. That makes perfect sense to me. I will definitely follow your guide and advice. I appreciate your help very very much. I have a lot to learn. Thank you again. Mike


#4

Hi,
I installed ImpulseRC driver fixer and am now able to connect my Vortex quadcopter to BetaFlight. I appreciate you taking the time to respond and giving me some suggestions. I am thrilled that I am able to connect to BetaFlight. . Thank you again.

Mike