Brushed Microquad motors spin when connect battery (QX70/QX90)

qx90
microquad

#1

I purchased a qx90 over the weekend and arrived yesterday thank you, I had problems getting it to arm the motors and after a bit of reading somebody said try resetting the software, now all good but I forgot to save a backup file of the programming before resetting and now the software is blank.

I have set up quads on cleanflight before but they have been brushless, I can’t seem to get the motors to stop spinning up when applying battery power.

Do you have any ideas as to why the motors are spinning up.

Before you ask I have enabled motor_stop, changed pwm rate to 3500 and checked my min/max in out values.


#2

In order to stop the motors spinning when you plug in the battery for brushed flight controllers all you need to do is set the motor_pwm_rate to 1000.

Using Cleanflight

Enter the CLI and type set motor_pwm_rate=1000

Using Betaflight
You can also use CLI, but betaflight has a handy option on the configuration tab that lets you select your motor type, and will adjust the corresponding settings automatically.