Walkera runner advance mix switch problem


#1

Hi. I’ve just received my runner advance and it flys really well, I also have a qr x350 pro. I’ve just had my runner in the air and the mix switch seems to be set to 0-GPS mode, 1-manual mode, and 2-RTH. What worries me is in the manual it says do not switch from GPS to manual as the aircraft may fall from the sky. I have to go from GPS, to manual, to RTH to activate the RTH. On my other Walkera quads, the default is 0-manual, 1-GPS and 2 RTH. Is there a fix for this in the devo f7 settings? I love Walkera products but these glitches are really putting me off. Please help me! Thanks.


#2

I think all they mean is that in GPS mode, throttle stick controls the altitude, but in manual mode throttle stick controls the throttle. When you switch from GPS to manual and your throttle stick OS low the throttle will be too low to keep the drone hovering.

So when you switch back to manual just get ready to take off throttle control.

I don’t have a runner advance so not sure how it works exactly but that’s how most things work.