Troubleshooting CubePilot Cube Orange+ USB/COM Port Issues

I recently purchased a CubePilot Cube Orange+ and it doesn’t appear to be working correctly. When I plug it in, it’s not recognised on USB/COM ports. I’ve tried with Windows 10, Mac and Linux, and MP and QGC. If you have any suggestions on how to proceed or how I could exchange it, that would be very much appreciated.

I’m sorry to hear about the trouble with your Cube Orange+. Here are a few steps you can try:

  1. Driver Clean: Disconnect the Cube from USB, open Mission Planner, press Control + F, click ‘driver clean’, then download and install the latest drivers from here, and reboot your system. Installing Mission Planner | CubePilot
  2. Device Manager Check: Look in the device manager to see if the Cube is connected to a specific COM port, even if it’s not named as Cube Orange. Then set this COM port in Mission Planner and try firmware flashing Cube Orange Connection Issues - Cube Autopilot - Cubepilot

I that still does not work, then please let me know your order number (if you ordered from us) or reach out to the store you ordered it from for some more details as it could be a defective unit. However most of the time its usually solved by flashing the latest firmware, or resolving any driver issues.