Static - no video in FPV goggles


#1

Hey guys, so meanwhile I’m waiting for my new Turnigy IA6C reciever after I did a short circuit, I recieved my new Eachine goggles VR-007 Pro,I connected my battery to the drone(without a transmitter reciever like I said before) powered up the goggles, and still no video in the goggles, altough my Eachine VTX02 is connected and I synced them both on the same channel, is it related to that I dont have a reciever yet? or there is a problem that I’m missing?
Thank you guys.


#2

VTX output wont be effected my your RX

If your getting static on your goggles then your either on the wrong channel or your VTX is not transmitting.


#3

Alright, so in order to make sure im in the right channel,I put my VTX02 on channel A1 which is 5865M and in the goggles on A1 which shows in the display 5.865GHZ, tried it in more channels and it didn’t show something.
So the next possibillty is that the VTX is not transmitting, how can I check that? it seems to be fine, connected and soldered, displaying the CH/FR and that its on.


#4

It’s hard to test without special hardware, but the easiest is to swap the vtx for another (or a friend’s) to troubleshoot shoot each item to narrow down the component causing the issue


#5

Unfortunatley not possible for me…I guess i’ll need to order another VTX to find out?