Quadcopter sometimes tips over on landing

apm
multirotor

#1

My copter is fairly tall and auto-RTLs when it runs low on battery. My backyard is fairly hilly and the GPS isn’t too accurate so sometimes it tips over when it lands. I have no control over this because of APM, which doesn’t let me control it after going into a battery (or probably any other kind of ) failsafe. How should I stop it from tipping over and chewing up the props (and at worst, flipping all the way over and cracking the GPS mast?)


#2

@RobbieGM
Hi
Just before it lands you should be able to put it in stabilised mode and bring it down the last few metres yourself
Moving your mode switch into STAB should do the trick even if RTL was instigated automatically either by TX off or failsafe
Cheers
Steve :grinning:


#3

You might want to play around with the max descend speed value to try reduce it a little as maybe your quad is descending too quickly, or the other option its its going down to slow so a sight breeze will cause it to drift catching on the ground causing it to flip. I cant recall off hand what th values are, but there are two values, one is the initial descend speed which can be quick, but then there is another value for the last few meters which should be set slower by default.

In general the best option is to get wider landing gear, Or land manually as suggest :slight_smile:


#4

Had a similar problem with my hex and the long-legged tripod-type landing gear that came with it. - tip-over after tip-over. Lost a few props that way (plastic practice props, to be sure, but lots of them broken none-the-less).

I bought a kit which allows me to attach several different devices to rails that are mounted to the under-side of the 'copter. I then made my own landing gear out of (hang on to your hats, folks) balsa wood popsicle sticks. Just glued a few of them together (flat-side-to-flat-side) cut them to size and shape, and attached them to the rails with small screws.

They have a wide-enough stance to negate the tendency to tip over on landing, yet they are strong and still light-weight.

Sometimes the older stuff works better than the newer stuff…


#5

I can’t land manually, it takes control and I can’t get it back. Is there a way to override failsafe?


#6

Are you still having the tip-over problem? If so, what Flight Controller are you using (brand name and model number)?


#7

Hi
Can you confirm your exact flight controller and what f/w level?
Cheers
Steve:slight_smile:


#8

It’s APM 2.6, not sure about the firmware version right now. I think it’s the latest one that can run on APM 2.6. Since it’s winter and there’s snow and I’m worried about the tip-over problem, i don’t want to test for the tip-over problem, so I’m not sure if I am still having the problem or not. I’m assuming that I do have the problem.


#9

Hi
I was thinking of the ‘can’t switch back to manual’ problem
I can only try this on a MINI-APM running v3.2.1 at the moment
Hopefully I can get to the flying field Friday pm or Saturday and will test it out.
Cheers
Steve :slight_smile: