Pixhawk and minimosd

osd
pixhawk

#1

I wonder if you can help me. I am running a pixhawk that I got from you the other day, and have plugged a minimosd into the Telemetry 2 port. I have flashed my minimosd with MWOSD 1.6, but it’s not reading any data. Do you know if I can even run the MWOSD firmware on the minimosd for the Pixhawk, I read somewhere it may not be the right protocol for the Pixhawk. Most people use minimosd-extra, and use the config tool to set it up, which I can’t do because I’m using an Apple Mac. Any suugestions? Thanks for your help.


#2

​Are you using the scarab-OSD form of the MWOSD firmware as I know that one does support Pixhawk/MAVlink, you just need to make sure the baud rate and protocol are set correctly.


#3

I flashed my minimosd with MWOSD 1.6, and I’ve just been reading the MWOSD webpage that says it does support Pixhawk, so it should work. As I say, because I use an Apple, I am having to use QGrond control and there’s hardly any documentation about activating the Telemetry 2 port (if this needs to be done at all). I’m just getting “No Data” on the screen. Have you used AMP Planner, is this better?


#4

I figured it out! It turns out I needed to define what FC I’m using in the config.h file, and it works like a charm.


#5

Hi, I’m having the same issue. Could you please explain how you fixed your problem.
I can not find any option in config.h to un-comment for Pixhawk or APM (both working with Mavlink protocol).
Could you please address me how to change settings to fix the issue? Thanks