Omnibus F4 V6 Flight Controller Guide


#1

Originally published at: https://blog.dronetrest.com/omnibus-f4-v6-flight-controller-guide/

The Omnibus series of flight controllers from Airbot is one of the most popular options available for BetaFlight pilots. However, apart from a pinout diagram you get with the board, there is little other information available for the latest boards. In this guide, we hope to rectify that and help you to get the most from your flight controller. What’s New…


#2

Hi Alex, please would you help me?

Its about camera control in Omnibus F4 V6 (OMNIBUSF4FW (OBFW) 3.5.2 )

I have a Runcam Swift 2 but I do not need Runcam Camera Control, I just want to use betaflight camera control OSD joystick emulation.

I have connected OSD pin from Runcam Camera to Camera Control pad in FC and GND pin to Ground wide pad in FC.

Camera control pad is supposed to be dedicated to this function so it does not need an additional resistor to work. I have checked Betaflight Wiki and RCGroups thread about Camera Control issues and CLI commands for Runcam Swift 2 that seem to work are:

camera_control_mode = HARDWARE_PWM (default)
camera_control_ref_voltage = 330 (default)
camera_control_key_delay = 470 (default)
camera_control_internal_resistance = 180 (default)

However I cant make it work, I can not enter into camera configuration.
I have tried with ref voltage = 293 because I got 2,93V between Osd and Gnd pins, but wont work.

Would please somebody help me? Probably the pin assignment is wrong as Camera Control resource is B09 but maybe this is just for Fireworks and its not the same pin for V6…

Thanks!!!


#3

Almost solved but I still need help …

It works BUT each time I enter the Menu or I press a button to move, the ESCs beep just the same way as if FC was rebooted , but it does not.

Why are ESCs beeping ? The two Beeper options for Camera control are switched off.

Camera model: Runcam Swift 2
Flight controller model: Airbot Omnibus F4 V6
Firmware version: Betaflight 3.5.2 (OMNIBUSF4FW (OBFW) 3.5.2 )
Pad label: Cam_control

resource CAMERA_CONTROL 1 B07 (changed from B09 to B07)
camera_control_mode = SOFTWARE_PWM
camera_control_ref_voltage = 328
camera_control_key_delay = 150
camera_control_internal_resistance = 474

No capacitor no resistance. Osd pin to Camera control pad and GND pin to GND pad


#4

So the ESC do the complete startup tone? But ignoring this are you able to access the camera osd menu and change settings just fine?


#5

Thats Ok, I am able to access the camera osd menu and change settings but ESC do the startup tone every time I press a “key”

Should I be worry? Thanks!


#6

I myself have not tested camera control with motors so I am not sure. I remember there used to be a similar bug with runcam camera control but was fixed with newer firmware so i suspect this is similar. It is not a problem if you only access the camera osd menu while on the ground.


#8

How so…

Can you screen shot it and show us?


#12

for me you have make a mistake.

you connect the SBUS to the RX6 AND gps to UART6, no chance that this configuration work !

i think that gps on uart 3 is a better choice :slight_smile:


#13

Servo 4 and 5 does not work for inav with firmware fireworks v2


#14

Check your resources to see if they are assigned to anything as maybe the in

Fireworks firmware doesn’t have them assigned in inav


#15

Hi Alex I just looked on betaflight and there is also a target that says omnibusf4v6 is that an updated version or should I still use omnibus fw?


#16

hi, I have create this target in Betaflight to avoid all the problems of resources, I will implement what is coming out but it is almost complete, definitions of I2C, resources, gyro, etc.


#17

Is there any battery voltage pads on this board if I rather power my vtx with a higher voltage to keep current down. Worried about over currenting the bec with the 800mw vtx and the camera ?


#18


#19

Will that pad have vcc on it if I’m powerung board from 4-1 esc


#20

If your powering the FC from a 4in1 then your get vbat and power to the FC from the 4in1 pin connector at the side of the FC.
image


#21

hey, I’m new here and I have a question.
“Non inverted serial receivers (Spektrum Satellite) are connected to the TX1 pad (right next to the SBUS pad)”. regarding to that sentence, isn’t receiver usually connected to the RX pin/pads? because flight controller is ‘receiving’ information from the receiver. I could be wrong tho…


#22

Yes you are correct, that’s a typo… spectrum should go to rx1


#23

Thanky for the great guide!

I have a question regarding the voltage sensor:
While trying to resolve my noise issues, I’ve burned the voltage regulator. Therefore I’m not able to feed my 3S directly to the FC.
The 5V input via the servo rail works fine and everything is ok, besides that I have no voltage while flying because FC can’t know what my battery voltage actually is.

So is there any way to use an external voltage sensor? Or any (I’m running Betaflight)


#24

Google this part:
Full Speed FSD-XT30 60A

and see if it does what you need