Omnibus F4 V6 Flight Controller Guide

Thanks for your reply. As I understand, this would be for the current.
But I need a way to measure the voltage.


I’m having issues with power on this board
I’ve got:

Racerstar 35A 4in1 ESC (brand new, connected via the 4in1 8 pin cable)
Fly sky X6B (connected to TX1)
Eachine TX5258 VTX (8V pad)
JJA-CM1200 cam (5V pad)
4 x DYS Samguks 2600KV

When I plug only the battery in (4S 1800mAh), the blue light on my board does not flash and the green light is very dim. When I power on my Tx, it gives me a low voltage warning for my Rx

If I plug the board into my PC via usb, blue light flashes and green light is on properly. If I also plug in my battery, the motors work (via INAV, not Tx)

Also, if I unplug my Rx, the FC seems to have full power ie both lights flashing properly.

I think it is most likely the Rx, but I’m not sure if it’s the board just not being able to supply power for some reason?

Any help or advice would be great


Hello fellow pilots, I have a question about the Omnibus F4 V4 FC.

Basically, I want to use it for a long range setup I’m building.

As of right now I have pretty much everything hooked up and running, but now I would like to make use of a SpeedyBee Bluetooth-UART module but I think I ran out of UART ports.

Currently I have:

UART 1 = SmartPort
UART 2 = VTX Smart Audio
UART 3 = GPS Module
UART 4 = none
UART 6 = Serial RX

So I was hoping to use UART 4 but on the FC there is no TX4 pad or at least I can’t find it.

What would be the best way to proceed? I was hoping to avoid Softserial if possible.

Thanks a bunch!

Hi everyone, I have burned out a component, guess it is 5V regulator. Can anyone tell me exact details so I can replace with a new one??

I wanted to create an on-off switch for a secondary set of led’s. I have an on-off controller and have done some reading on using a servo configuration to activate it. It does not seem that the servo pads/holes are assigned to any resources. Is there a way to assign the servo pins to a resource to use as an output on a quadcopter setup?

I’m having issues with iNAV setting up this board and would appreciate any feedback.

  1. I’ve tried flashing with both Fireworks and the Omnibus F4 V6.
  2. Accelerometer calibration results in incorrect orientations after the first two are good.
    Note : Airbot stated MCU isTOP, USB is FRONT.
  3. Using SBUS on UART6 Rx all good.
  4. Cannot get GPS (Matek M8Q-5883) to work. Calls for UART6, so switched to UART3 since SBUS has UART6.

i consider myself very good at setting FC’s up on inav. the problem with this board is the firmware uses either SDL or SDA for another thing and you cannot resource with inav. ive tried many different ways and never got both gps and compass working together.
i use this board in racer now and using matek with pdb for inav perfect.
Please stop banging your head against the wall and stop trying to make it work, IT WONT.