New build Beeper not working (Solved)

Hi. I have just bult a new 5" FPV racer and I cant get the beeper to work can anyone help please.
FC = Matek F722-STD Flight Controller with Built-In OSD
VTX = Matek FCHUB-VTX 6~27V PDB with 5.8G 40CH Switchable Video Transmitter
Beeper = Matek DBuz5V Lost Model Beeper & FC 5V Buzzer
Betaflight = 4.2.2

As you can see in the image I have connected the buzzer to Gnd, 5V and Buz- like all the instructions say (same as I have done with 2 other quads fine) however when I assign a switch on my transmitter to beeper it doesn’t sound the buzzer when on am I missing anything I have tried 2 buzzers so I doubt they are faulty.

should voltage be coming out of the B- on the buzzer as its kicking out 5v

Also what is the Buz- on the FC supposed to do when you flick the switch.

having the same problem… all wiring seem correct…did you end up finding a fix?

Its most likely due to the settings on your FC for betaflight.

The best way to test this is to assign a switch to activate it. In Betaflight’s Modes page, scroll down until you see “Beeper”, and assign a switch to activate it. To turn off the beeper for certain conditions if you find it too annoying, you can also turn it off.

I hope this helps! Let me know if you have any other questions.