How to upgrade your FRsky Receiver firmware (X8R, X4R, X4R SB)

taranis

#1

In this guide we will show you how to upgrade your Frsky X series R/C receivers with your Taranis Radio via the smart port.

What you need?

Standard servo cables have the red voltage wire in the middle, however you need to change one end to swap the voltage and ground pins around and the other end connects to the smart port of your receiver. This is very easy for the X8R receiver, In the case of the X4R, or X4R-SB upgrade, a cable is already included with the receiver. All you need to do with the X4R cable is also swap the servo connector end so that the red wire is on the end and ground is in the middle.

How to connect X4R

How to connect X8R, X6R

How to upgrade the firmware

Its a good idea to make sure your Taranis radio is fully charged as you could brick your device if the battery dies in the middle of the firmware upgrade process.

  • The first thing you need to do is download the latest firmware from the FRsky Website for your receiver.
  • You will also need to extract the firmware .frk file into the firmwares folder on the micro SD card in your Taranis radio
  • Now turn on your taranis and long press the menu button untill you enter the SD card browser, then navigate to the firmwares folder.
  • Now you need to select the firmware .frk file that you downlaoded for your receiver.
  • once you press enter a sub menu will open where you must select flash external device option.
  • You wlll then see a progress bar showing the progress of hte firmware flashing process. Once done you can turn off your taranis and unplug your receiver.

If you have any issues getting this working please let me know and I will be happy to try help.


FrSky EU LBT Firmware
How to upgrade Frsky XJT module (internal module in Taranis)
How to upgrade Firmware for FrSky Taranis X9D
Flash XSR mini firmware
Getting taranis x9d plus to flash your x8r
How to upgrade Frsky XJT module (internal module in Taranis)
D4R-II cant bind to taranis (LBT firmware) - no D8 mode
#2

I just burned my X8R. Well, at least that’s what I think as it won’t power up anymore after “firmware update error”.

Why? - The GND and +Vcc pins on your picture are swapped (on Taranis picture). The +Vcc pin is in the middle.

Anyone has a spare XC6201-332?


#3

Thanks for pointing that out, the images above are wrong :disappointed:. I guess that is what happens when you try make diagrams too late at night! I have just fixed them so thanks for pointing that out.

As for your X8R, doe you get any LED’s now when you apply power to it?


#4

Hi! Good there was at least some use for my failure :slight_smile: (I mean pictures fixed and others will do better).

As for my receiver - nope, nothing lights up when I power it up.

First time after connecting and getting “firmware update error” (before I realized the polarity was wrong) I powered the receiver up and got both green and red LEDs solid, that’s when I started suspecting something went wrong. The next time I connected it correctly to the Taranis I got the same error, but after that LEDs wouldn’t light up again.

So I suspect the voltage regulator got fried (at least I hope it’s the only thing fried :slight_smile: ), will verify that later. In the meantime ordered a bunch of XC6201P332 (will arrive in something from a week to a month and a half).


#5

Hi are are the pictures/ diagrams right now ? How to connect X4R ?


#6

Yes I updated them as the VCC pin is the middle pin of all the 6 pins on the taranis module. The first diagram is for X4R :slight_smile:

So from the bottom pin on taranis is signal, then ground then voltage.


#7

just updated worked great ! note when i powered up external module up set it to ppm lol


#8

HI , when I select the sub menu, I only have “delete”, the rest of the sub menu is missing. Can you tell me why ? thanks


#9

I’m honestly not sure, as havnt had this issue myself, but my guess is that maybe you don’t have the correct firmware file?

The other issue could be related to your taranis bootloader/firmware version as it needs to be newer than 2.1.0


#10

You are right, my firmware version was too old. the issue is fixed, many thanks


#11

Hi all!

A small update from me: I managed to replace the fried XC6201P332 voltage regulator on my X8R - and it seems to be working (blinking led, etc).

Doesn’t bind to taranis, though (both leds are on if powered with FS button pressed). Will try updating the firmware again :smile:


#12

Okay, flashed the firmware and successfully bound to Taranis, connected servo works :yum:


#13

I have a Taranis + fw 3-something. I have never come across the SD-card menu. When I press menu briefly I come to Model setup. Press a second I come to Radio setup. If I press a minute, still nothing more than radio setup. Tried to google SD-card menu, but with no luck. Can you offer any help?

Sorry, found it in the submenu under Radio setup…


#14

I am having a problem getting my Taranis to bind after I updated the firmware. It will not bind to anything now!!! I accidentally erased the File of the SD card, and now I can’t find it anywhere? I tried even using OpenTX and re flashed my Taranis with the latest firmware, but still no luck!!! It’s been a week now of me searching the internet and watching videos and people telling me how EASY it is , and that I only need to update the Taranis firmware. Well I’ve tried all that, and using OpenTX and it still won’t bind!!! When I go to the FRsky site, the files are a .rar extension and I can’t put that on the SD card? Where do I go to get the .frk files?? I’ve looked everywhere and am getting ready to loose it, and just go back to Spektrum :frowning:


#15

You can download the frksy update files from their website. But did you load the LBT firmware onto your taranis? If so you will also need to load LBT firmware onto your receivers for them to work, otherwise you should go back to the international firmware. Also another thing to double check is to make sure both your receiver and taranais are set to the same mode, D8, D16 etc…


#16

Wow. Great job Yurique. You wouldn’t happen to live close to Washington State, USA. lol


#17

Where did you get the voltage regulator for your receiver?


#18

Hello! Help me please
Could you say about XC6201-332? My X8R not power on after flash firmware fail too.


#19

i get this error when trying to flash my X4rsb eu to non eu i have a taranis qx7 with international firmware.im connect via smartport. I managed to power the rx from the back if the qx7 but had to change my external rf settings to ppm to get power. Plz help


#20

Can only post 3 replies, logical, but sometimes maybe not handy;

YES, Hero! it works. I did try it but with the crossed servo cable, with the straight one in the future use plug, it works perfectly.
Many thanks for sharing this!!!