How to reset BetaFlight OSD? Showing strange characters and symbols, and font on screen?

osd
betaflight

#1

I was able to Install my new FC today on my quad (Diatone Fury F3) , but i have the following problem:

  1. I connect the lipo to the copter (my goggles are powered up)
  2. I see the video from the camera perfectly fine in the goggles. (Without OSD)
  3. The FC boots and makes beeping sounds.
  4. I See the video feed again but with a weird OSD with loads of random chacters displayed.

Any suggestions?


#2

We have had this issue before and 99% certain hat its just a setting issue, what you need to do is reset your font cache on the OSD chip… do that you need to do the following:

  1. Plug the Lipo
  2. Plug the flight controller to a configurator (Betaflight)
  3. Go to OSD tab
  4. Click on « Font Manager » in the bottom write corner
  5. Select the desired Font and click « Upload Font »

Once you have tried that it should display correctly :slight_smile:

Update: IF you still have the same issue after updating the fonts, make sure the FC is powered via Lipo, as sometimes the USB cant provide enough power for the OSD module.


#3

Thanks a lot! OSD works now perfectly!