Double Whammy FLASHING FlySky FS-T6 and TGY i6 Transmitters


#1

I have a Tournigy TGY-i6 which I have just flashed. That did not help with the problem that I cannot get ANY changes to stick. The OK button effects the change you want, leaving me no way to back out. Cancel, cancels the change, OK just changes it again. AARRRRRGH How are the changes meant to stick???

The FlySky Tx works OK, but I cannot update the firmware, I tried the 10ch_mavlink_mod_i6_programmer_v1.exe file, which seems to be a self executing updater file.
It brings up a window where I open the port (correct one according to Device Manager). The port then opens. When I try to flash it, it says the Tx is “not connected” even though the OPEN changed to CLOSE for the port. Really frustrating. I tried other update packages, with no success. And yes I am running it in Administrator mode. Stumped.

Anyone got a clue?


#2

I might not understand the problem.fully, but flysky radios are definitely weird in the fact to save a setting you need to loong press the cancel button for about 1 second. If you short press cancel it will edit the menu without having.

As for flashing are you sure you are using a correct baud rate


#3

I should have been able to figure out that it needed a long press. There was no extra button, so what was left, according to Sherock, must be the answer.

Thanks

This time round I checked the port speed. It was 9600. When I try to program the transmitter it says the device is not connected. I selected the port revealed by Device Manager, and the button saying Open Port changed to Close Port, implying it had opened. I have no idea what this contradictory presentation of open/closed information is telling me.