DJI HD FPV Firmware Update V1.00.02

Just a heads up about a new firmware release from DJI today that adds some awesome new features like full osd support!

Download the update here:

https://www.dji.com/uk/mobile/fpv/info#downloads

New Features

  • Added support for recording AV IN analog video transmission.
  • Fixed issue: display issues appeared in AV IN analog video transmission.
  • Optimized AV IN analog video transmission to improve real-time performance.
  • Added ability to customize the on-screen display information for the goggles, which supports 24 OSD
    items of information items in total. (To display GPS information, enable the UART port which is connected
    to the GPS in Betaflight software)
  • Added ability to adjust frame rate and bit rate according to distance and channel bandwidth when the
    transmission distance is more than 1 km.
  • Added support to connect the remote controller via USB cable to PC to play the simulator. (The simulator
    software needs to support USB HID input)
  • After activating the goggles, it will enter Channel 1 by default.
  • Optimized UI menu of PID Tuning.
  • Optimized microSD card error type. “SD card full” appears when the microSD card is full during recording.
  • Fixed issue: playback speed was slow when playing 120fps video on the goggles.
1 Like

Didn’t expect that one this year, nice! Guess all the famous Youtubers were caught by surprise too, as I haven’t seen any tests yet.

Its also a nice coincidence with the URUAV AV module and the DJI AV recording ability… I have one on the way to see how good (or not) it actually is… but if it works well will be perfect:

Note: a few people reported issues with the update showing a black screen for AV in https://forum.dji.com/forum.php?mod=redirect&goto=findpost&ptid=203425&pid=2021390

Edit: had this issue, resolved by doing reset all in settings. Apparently if that doesn’t work you can just scale the display to 70% and back and restart the goggles to get av in back - one good tip I found was if your screen is black that’s a bug, if it’s blue that means there’s no signal on av in (useful when you’re not sure if it’s your jerry-rigged cable or just a bug :slight_smile: ).

Really happy with analog performance and especially with DVR, here’s a quick sample: