APM2.6 only booting with USB connected?


#1

Hi, i bought a apm 2.6 with power module last week … iIve tried setting it up and got most of it working ok … its just that i can only get the esc/motor to run by booting it from the usb …it arms on just the battery but the motor wont run …i see theres loads of threads on the net regarding this , can you tell me what to do to resolve this problem ?


#2

Sorry about the problem you are experiencing. From the sounds of it the board is not getting enough power without USB. Could you please double check the pins on the APM board where you connect the power module (as many times they can be bent). They are very small so might be good idea to use magnifying glass or something to see properly).

Also could you also check the power module cable and pins to ensure there is a good connection on that too.

Otherwise if you connect the JP1 (and remove power module) and power your APM via one of your ESC’s does that work?


#3

Hi

I’ve just fitted the jumper and its still the same ok with usb connected it then runs ok till i disconnect the battery then when i reconnect same problem motor only runs with usb connected.