APM 2.8 compatibility with APM planner 2 on Mac

apm

#1

I’ve recently purchased APM 2,8 manufactured by unmanned tech. Can I use it on APM planner 2 on mac.As I’m unable to do the initial setup.


#2

Hi

You should be able to use it with mission planner 2 on your Mac system. But could you please give me some more details on what the actual problem is? Have you installed the latest firmware. When you plug it in via USB do you see and LED’s flashing on the APM board?

However depending what version of OSX you are using you might need to manually install the drivers to connect to your APM board, as this is a common issue.

Installing FTDI drivers for APM on your MAC

Once you have downloaded mission planner 2, you should open the file location and inside you will see the FTDIUSB serial driver .dmg file which you need to install. Inside the .dmg file you will see two more files. Open the file with 10_4_10_5_10_6_10_7 by holding the command key before clicking to say open.

You might get a message saying the driver is for !)_7, but its the correct one to use for all OSX versions up to 10.10.

Follow the FTDI setup wizard and once installed you should be able to connect to your APM board.


#3

I have done the requisite steps but its still not working, i have attached the screen shot of the error, do i need to install any extra drivers as I’m using OS X el capitan version 10.11and I’ve purchased
http://www.unmannedtechshop.co.uk/apm-2-8-flight-controller-board/


#4


#5

Thanks for the screenshot, that seems like its an issue with some security on your Mac, as its not letting the mission planner connect to the servers to download the latest firmware. You will find that you will get this error even if your APM board is not connected to your PC.

I am not that familiar with OSX, but I do believe you can add mission planner to the exception list on your firewall to allow it to download the firmware.


#6

Hi

Just to let you know I am running OS X 10.11 and APM planner 2 without any issues. I didn’t have to do anything extra to get it working. Alex’s firewall suggestion is the likely cause as I don’t run a firewall on my mac I would not have seen this error.

Cheers,
Chris.


#7

Hi…
I have experienced

checking the avrdude installed on macbook

$avrdude

install reference…
http://wiki.xinchejian.com/wiki/Install_avrdude_on_Mac_OSX_Lion


#8

Hi Chris
Thanks for your reply.
I’m also not using the firewall on my mac.Could you please tell me how did you do the initial setup.
and which product are you using.

Regards.


#9

Hi
I tried again and its showing a new error that it couldn’t open com port but the firmware got installed