Aomway commanders not powering up


#1

I just got a set of Aomway commanders. These goggles work with 2s to 4s batteries, well I tried 4 different fully charged 4s batteries on them today and they will not power up.
Has anyone else had this problem or know the answer.


#2

I spoke with you over email, but just incase anyone else has a similar issue, the porblem was with the filtered power supply unit. But if your goggles are not turning on its worth checking the battery itself is charged, and then use a voltmeter to check if the filtered power supply is outputting any voltage to the goggles.

In your case we will get a replacement power filter sent to you tomorrow :slight_smile:

But the other option is to use one of the fatshark style batteries directly with the headset.


#3

I have checked the out put from the power filter with a freshly charged battery.
Thank you so much for helping resolve this issue so quickly.

Paul Wilson


#4

We sent you out a replacement power filter so if it’s not there already it will be with you soon, so hopefully it will all work now :slight_smile:


#5

It arrived today and worked perfectly. Great customer service and a great product I will be shopping with you again.

Paul Wilson