T16 Pro Nightmare - SD Card

So I’m having a nightmare with my jumper T16 Pro. Given the comments about how the SD card that comes with it aren’t that great, I’d go with the recommendations of using a new SD card with latest firmware on it. Subsequently - the nightmare began when I started copying my models from the ol’ trusted X9d+ to the T16 via OpenTX Companion 2.3 (latest version).
Two profiles set up one for the X9D+ and one for the T16 (used Horus X10 settings)
Converted and copied models across.
Saved the new models, then re-opened them to check that they’d saved - yep. :slight_smile:
Disconnect the USB lead, turn off the jumper and then turn it back on again, and get this…

Then followed by this…

The unit then goes back to default configuration and you have to calibrate the sticks n pots and it goes back to default model i.e. you lose all your previous model configs.

After much cussing, I went back to the original SD card only to find that when I made changes to the models or tried to copy a model across it did exactly the same thing. I’ve since tried multiple SD cards, rebuilt them with FAT16, FAT32, latest firmware (2.3), latest SD card from jumper website, old firmware (2.2.3), old 2.2 SD card contents, and all the same error messages as above.

So just wondering if anyone else has seen this and fixed the issue, or is it that I have a faulty unit that needs sending back :frowning:

Any help as always - gratefully received.

I was already doing what you suggested on my post. Then I got a brand new sd card and formatted it and loaded on the jumper t16.2.3 sd version and firmware to go with it with a usb sd card reader, put it in the t16 and still got exactly the same results that we already have. This is the first tx I have ever bought and am at the extent of my knowledge. Where do I go from here ???

I’m sending mine back unless @UnmannedTech can come up with an idea for a fix. Last ditch attempt; I’ve bought a 4Gb SD card and tried formatting it with FAT. Same issue. Looks like I’ve got a dud unit. :frowning:

I’ve been talking with Joshua Bardwell and he said to, for the sd card, try changing the version text file from hidden to unhidden

In windows you can change it’s attributes. Let me know what you think @GrandFromage

I think your issue is that you used the opentx companion to copy stuff around. It’s not supported yet by the opentx devs. I would suggest finding a way to wipe the radio back to its factory settings for both the radios internal firmware and the sd card contents and see if you still have the same issue

Would wiping the sd card achieve this @wyntrblue

Tried that I’m afraid - didn’t do anything to solve the problem. :frowning:

Tried this as well; downloaded the whole sd card from jumper. Formatted a working SD card and copied the files across using Windows explorer to give myself a new build. Same problem :frowning:

Yes its very frustrating isn’t it :frowning: @GrandFromage

Sdcard is not the same as the firmware on the radio.you need to flash the radio firmware back to stock before you do anything g else.

You also don’t actually need an sd card at all. So take it out of the radio see if you have the same problem

If I recall correctly, there’s a “hidden” file in the jumper SD card contents that needs to be copied across - check the SD contents you’ve downloaded from Jumper and make sure you are able to view hidden files (in Windows 10, click the “View” tab in File explorer, then check the “Hidden Items” box on the right), and also make sure you copy across any hidden files you find. Why it is this way, I have no idea, but it solved the issue for me before :slight_smile:

Yep that’s the version number of OpenTX. The firmware has to match.
Alas done that and it didn’t solve the problem. :unamused:

Here is what Oscar Liang told me to do. And it worked
You sent me a screenshot of your SD card directory from your T16 ,which only shows 3 folders. You should have 10+ folders there.
I think you might have copied the SD card content wrong
From the file you downloaded from the T16 website - “t16-sd2.3v0020.zip”
unzip this file, go into the “T16-SD2.3V0020” folder, here you should see this:

[Image: CKRZ9AOl.png]

Now copy everything here directly to the root directory of your SD card
Hope this helps @GrandFromage