RSSI with spektrum

spektrum
osd
betaflight

#1

Hi guys, can anyone tell me if it’s possible to get RSSI displayed on my OSD when using a DSMX sattelite? Any input on the matter would be great.


#2

I dont fly on Spektrum so am not much help, but I have found this information… apparently you just enable RSSI output via the CLI for your receiver and set the output channel.

Use commands:

set spektrum_rssi_enabled = 1
set rssi_channel = 9
save

Then go to the receiver tab in betaflight to tell which channel is reporting RSSI (the same channel you set the RSSI in the step above). Remember to press the save button when done.

Then the last step is to enable RSSI on the OSD

Let me know if that works as I scraped together this guide from doing some reading online :slight_smile:


#3

Don’t forget:

Aux 12 in betaflight is Channel 16 on your transmitter.


#4

I found that the command “set spektrum_rssi_enabled = 1” shows as an invalid command, however when i typed “set rssi_channel = 9”, changing the 9 to 8 as i use a Dx8, it works as it should. Thanks for your help, i now have some reassurance in how far away i can fly and still be safe. Thanks again, you guys are a mine of information.


#5

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.