Omnibus F3 AIO quickstart guide

omnibus
betaflight

#43

Hi can I use 20a little bee secs with f3 board ??


#44

Yes you can :slight_smile: You can pretty much use any Blheli, BLheli_s ESC with this board.


#45

Glad to be in the group. I’m trying to set up a 350 hex with Inav on the Omnibus F3 V1.1 and have an issue with motors 5 and 6. Only 1-4 show up. I’m seeing somewhere that pwm 5 is used for leds. What’s that all about? Is there a way I can map pwm 5 and pwm 6 to be what they’re supposed to be, motor pins?


#46

can you change the drop down box from Quad X to Hex.

Then click Save and Reboot


#47

Yes, I’ve checked off hex X. I’ve solved the problem. Seems if there’s anything connected to uart 6 then pwm 5 and 6 are reassigned to another function. Seeing as uart 6 the traditional connection for the receiver I had to switch the receiver to uart 1. Gnd, rx, +5v. If uart 6 is left empty all motors show up. So, if you’re building a hex you only have 2 available uarts, uart 1 for the receiver, uart 2 for GPS, and of course i2c for compass. Uart 6 must be left unassigned in Inav. I suspect this is true in Betaflight and Cleanflight as well although I haven’t tried those. Hope this helps others trying to build a GPS hex in Inav. It took some digging to discover this.


#48

Hola Jesus! tengo el mismisimo problema. Lo has podido solucionar?


#49

hola, si lo pude hacer. Hay que configurar el failsafe en la emisora también. Hay muchos videos en YouTube de como hacerlo. Te será muy útil. Saludos y espero haberte ayudado. Buenos vuelos!


#50

I’m sorry… doesn’t know it was only in english. The fact is: i have a Flysky RC with an FS iA10B receiver… my FC is the flip32 omnibus F3. When I do the connection via the uart3/ppm/sbus, the drone works well, but when I turn off my transmitter, the failsafe doesn’t work. I configured it in the betaflight and in the transmitter, but nothing happen. I tried to connecting via uart2 and ibus, but this doesn’t work too. Any suggestions?
Thanks again and sorry for my poor English.
Ricardo Bordenave from Buenos Aires


#51

First off…

Thanks for setting testing and setting up fail safe… Some people skip this step on there build or just don’t test it.

Have you had a read of this guide I found online??
https://www.propwashed.com/ibus-betaflight-guide/

I think your English may be better than mine