Mobula7 won't take off

Hi everyone, I wonder if you can help me
I am having a problem with my Mobula7. It starts up fine with all the right beeps and chirps , even the right beeps when I arm it but then when I try to take off it makes the same beeps as arming it does when I raise the throttle and doesn’t take off. Everything checks out in betaflight , transmitter and battery limits included and I am at the extent of my knowledge.

Any ideas? Thank you

do the motors spin when you arm? assuming you dont have motor stop enabled

I don’t know I haven’t tried it with motor stop enabled. But they run up on the Betaflight motor tab just fine and everything looks good when I do a status check in the cli tab too

under the receiver tab do all your sticks go from 1000 to 2000 with 1500 as the centre
also whats your ‘Stick Low’ Threshold set to

Solved. solved the problem for me. The PID loop frequency was to high which caused the CPU load to be running at 100% so I changed the PID loop to 4K and the CPU load went down to 24 % and away it fleww. So thank you Tmac

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.