How to upgrade your FRsky Receiver firmware (X8R, X4R, X4R SB)

HI , when I select the sub menu, I only have “delete”, the rest of the sub menu is missing. Can you tell me why ? thanks

I’m honestly not sure, as havnt had this issue myself, but my guess is that maybe you don’t have the correct firmware file?

The other issue could be related to your taranis bootloader/firmware version as it needs to be newer than 2.1.0

You are right, my firmware version was too old. the issue is fixed, many thanks

1 Like

Hi all!

A small update from me: I managed to replace the fried XC6201P332 voltage regulator on my X8R - and it seems to be working (blinking led, etc).

Doesn’t bind to taranis, though (both leds are on if powered with FS button pressed). Will try updating the firmware again :smile:

Okay, flashed the firmware and successfully bound to Taranis, connected servo works :yum:

1 Like

I have a Taranis + fw 3-something. I have never come across the SD-card menu. When I press menu briefly I come to Model setup. Press a second I come to Radio setup. If I press a minute, still nothing more than radio setup. Tried to google SD-card menu, but with no luck. Can you offer any help?

Sorry, found it in the submenu under Radio setup…

I am having a problem getting my Taranis to bind after I updated the firmware. It will not bind to anything now!!! I accidentally erased the File of the SD card, and now I can’t find it anywhere? I tried even using OpenTX and re flashed my Taranis with the latest firmware, but still no luck!!! It’s been a week now of me searching the internet and watching videos and people telling me how EASY it is , and that I only need to update the Taranis firmware. Well I’ve tried all that, and using OpenTX and it still won’t bind!!! When I go to the FRsky site, the files are a .rar extension and I can’t put that on the SD card? Where do I go to get the .frk files?? I’ve looked everywhere and am getting ready to loose it, and just go back to Spektrum :frowning:

You can download the frksy update files from their website. But did you load the LBT firmware onto your taranis? If so you will also need to load LBT firmware onto your receivers for them to work, otherwise you should go back to the international firmware. Also another thing to double check is to make sure both your receiver and taranais are set to the same mode, D8, D16 etc…

Wow. Great job Yurique. You wouldn’t happen to live close to Washington State, USA. lol

Where did you get the voltage regulator for your receiver?

Hello! Help me please
Could you say about XC6201-332? My X8R not power on after flash firmware fail too.

i get this error when trying to flash my X4rsb eu to non eu i have a taranis qx7 with international connect via smartport. I managed to power the rx from the back if the qx7 but had to change my external rf settings to ppm to get power. Plz help

1 Like

Can only post 3 replies, logical, but sometimes maybe not handy;

YES, Hero! it works. I did try it but with the crossed servo cable, with the straight one in the future use plug, it works perfectly.
Many thanks for sharing this!!!

I have not tried with the the x7 so maybe it doesn’t work yet? Will need to try myself to see if i can figure it out, although i don’t see why it’s not working. I will also try contact our frsky engineer to see if they know the secret to get this working.

However for now it might just be easier to update firmware on the x7 to be the EU lbt firmware

1 Like

Can only post three replies, 3 questions, not the solution!? :slight_smile:

YES, Hero! it works. I did try it but with the crossed servo cable, with the straight one in the future use plug, it works perfectly.
Many thanks for sharing this!!!

Cannot post another reply (limit to 3 replies!?!), only edit this one, so hope you read this;

YES, Hero! it works. I did try it but with the crossed servo cable, with the straight one in the future use plug, it works perfectly.
Many thanks for sharing this!!!

Created an account just to reply to this post as i was having the exact same problem. I was trying to flash a X4RSB receiver with non-eu firmware using my Taranis X7, but to no avail. After several hours i started pulling my hair out, was about to give up when i decided to stick that damn servo cable into the “unused” TF port on the bottom of the radio. Pressed “flash ext. device” and to my gigantic surprise it started writing the firmware into my X4RSB. Unplugged, bound successfuly. Correct pin order is GND, +5V, SIG, as on the photo.


Had to create an account to thank you for this post. I was getting frustrated and started wondering if what FrSky call the “smart port” would work and was going to start poking around with my meter.

Saved me a lot of headaches, thanks.

A post was merged into an existing topic: Help me binding an 4ch x4r reveiver to my Q X7

I bricked 2 x4r-sb’s!

I read the responses and your Howto.
I followed it to the letter.

The first x4r is from China and wouldn’t bind. So I thought I needed to update. I did.
The progressbar started, red and green lights flickered, then it ended with the error “defice refused the update” I downloaded this firmware from FrSky:


Which should be the right one.

When I power up the receiver it’s completely dead. If I try to update it responds: no response, can’t update.

I thought I might have bricked it because I didn’t fully attach the connector to the Taranis. I tried again with my “old” receiver (chopped of the antenna’s, bought it in NL, never messed with the firmware). It bricked the same way. So I have 2 receivers bricked.