How to connect foxeer and aomway fpv gear


#1

I’m trying to add an FPV camera to my drone but I’m not sure how the wiring should go. Can someone help me with this, please?
I’m new to this “environment”. sorry if it’s something too obvious.
I’m using an Aomway tx001 and a Foxeer XAT600M camera.
So far I’ve connected the 12V and ground pins from the PDB to Aomway and from the Aomway I’ve connected another cable to the camera - output 5V, ground & signal. I’m not sure though if I need to connect anything else to the FC or do anything else to it.


Naze 32 Revision 6 Flight Controller Guide
#2

The fpv system does not need to be connected to FC at all. The only time it is is when you are using an odd that displayed flight info on the video feed.

But in your case it’s separate as I don’t think you are using an odd?


#3

Nop. Just the FPV goggles.
Thank you for this! much appreciated!

Can I as something else though?
I’ve been trying to connect one of the “+” pins from the PDB to the VBAT pin (and the ground pin). But then if I try to plug in the USB cable, the board would not power up (I normally get some lights when I use the USB cable). In CleanFlight it says that it can’t recognize the port and no lights show up. I went through the steps that were suggested here but nothing changed. If I remove the VBAT cable, then it works fine. :frowning: Do you know what could be the issue?


#4

What FC are you using? And also what ESC? A photo or two will also help.


#5

this is my drone: It’s an Armattan Chameleon.

and my wiring diagram

I’ve used references to make it look cleaner.


#6

Something else to add to this is that the I can’t arm it now either. a) the motors work if I try to go to Motors tab and run them from there. b)I have a beeper attached to the drone as well so if I switch it on, then I can hear the beep. - in which case I would exclude the fact that the transmitter does not talk to the receiver.
I’ve also tried to change the arming switch… but no luck.


#7

Thanks for the diagram, makes it much easier and it does all seem correct in my opinion.

If your quad is not arming the most common cause is the throttle range is not correct. Go to the receiver tab in betaflight and make sure that when your throttle stick is down, that its reading below 1050 (best if you get it to 1000), as I know betaflight will not arm if your throttle is above this (or something close as I cant remember the exact throttle value). To do this you will need to use the sub-trims option on your R/C radio/


#8

I set the throttle to 1050 and now it works well!

Thank you for this! much appreciated!