ESC Beeping Non-Stop when wired through Pixhawk

plane
esc
pixhawk

#1

Hi,

Is there something I’ve missed to pass through the throttle signal from the receiver, through Pixhawk to the ESC?

The ESC beeps continuously when armed.

I’m using QGC 3.0.2 with the Flying Wing/Skywalker X5 Firmware 1.5.1dev. The ESC calibration seems to work though QGC - 6 beeps which matches what the manual says ( 3 beeps for 3S battery + 3 beeps for ready).
The ESC is a Overlander XP2 40A SBEC.

The servos are plugged in to the Pixhawk main pins 1 & 2 and the ESC is plugged into pin 3.

With the plane armed, the aileron servos work fine but the motor does not spin, just the very loud beeping from the ESC.
I’ve tried measuring the external battery voltage and recalculating the multiplier, changing the ESC connectors about and multiple different batteries with all the same symptoms.

According the the Overlander manual, continuous beeps mean that it’s not getting a throttle signal. The ESC is plugged in to pin 3, next to the servos.

I’ve tried two different transmitters a FlySky i6 with an iA6B receiver using PPM and a FrSky Tranis Plus with X4R receiver using SBUS.

BTW, it’s definitely my configuration of Pixhawk that’s wrong because the ESC works fine connected directly to a receiver.

Hoping it’s something really simple!

Thanks, Tim


#2

Hi
This may be nothing to do with your problem … but …
I found with my Mini-APM’s (similiar to Pixhawk) that if you do not have TX throttle stick low when powering up the FC funny things happen with the ESCs…

Cheers
Steve :slight_smile:


#3

Thanks Steve. It’s all working and happy with APM Planner setup. I’d like to get the same with QGC setup because it has the Skywalker X5 specific firmware. I’m planning to maiden fly tomorrow, if there’s any problems and there’s anything left of the plane, I’ll restart with QGC.