Binding ELRS with TX16 - Bind Phrase Issue

I bought a TX16S Mk2 ELRS and a Matek F405 WTE - and I’m completely stumped getting the two to bind to one another!

The documentation for the F405 WTE is a bit thin! I’ve flashed their suggested firmware on to the Rx via WiFi. It says it’s in binding mode (LED flashing slowly) for 30s after power-up.
Select Bind in the ExpressLRS Lua script. A dialog appears on the Tx, trying to bind - but the F405 doesn’t bind then goes on to the WiFi connection (LED Flashing fast).

I have the F405 WTE running iNAV. That appears to be working OK.

In the ‘manual’ it says ‘Bridge TX2 to ERx, RX2 to ETx’ - which I’ve done. In iNav, UART2 is pre-configured to Rx - though I wonder if the receiver binding is independent of iNAV, almost like a seperate Rx that just happens to be on the same module?

I can’t find any info / videos on line about the WTE version - and I’m starting to wonder if the two are actually compatible at all?

Any ideas?

Sorry to hear about the hassle you’re having with this!

Frustratingly, ELRS doesn’t appear to have their own page on the Matek WTE board, however, I did find this elsewhere online;

“ESP8285 has ExpressLRS fw 2.x preloaded with binding phrase “123456”, the Receiver will never enter binding mode if using the traditional binding procedure. It must be flashed without a binding phrase to do traditional binding OR flashed with your binding phrase.”

Using this information, it should be possible to achieve a bind to an ELRS 2.x firmware radio by flashing the receiver either with no binding phrase (for traditional binding) or with your own binding phrase following Matek’s documentation from this page;

Flight Controller F405-WTE – Matek Systems

If WiFi flashing is causing issues, I would recommend flashing via UART (steps available on the page above).

I hope this helps!

Thanks for getting back to me.

I can’t find an option on the TX16S to set the binding phrase anywhere?

Since I couldn’t find how to set the binding phrase on the Tx, I figured I could remove it on the Rx…

I can connect to the Rx via WiFi OK, but using the ExpressLRS Configurator, there isn’t an option for the Target device which seems to match the F405 WTE.


Regardless of what combination of device & Category, once it has compiled it warns that the target is incorrect & it may brick your Rx! I decided not to try that!

One step forward, two steps back!

I can see that you use the ExpressLRS configurator to set the bind phrase on both the Tx & Rx

I gather that the default for the TX16S is 3d7d96 - and it will only do ‘traditional’ binding if this is disabled, much the same as the Rx.

Unfortunately, Win10 will not connect to the RX16S, saying the driver will not start.
Since I can’t update the TX16S, I tried setting the Rx passphrase to 3d7d96 - but it still doesn’t want to bind.

So I have more understanding - but still no success! It’s frustrating that I’m stumped on what should be the simplest thing to set up.

Do you think it would be worth ordering another Receiver, known to bind to the TX16S and connect that to the flight controller? If so, can you sugest one?

Thanks in advance,

We have had this issue with a customer on our helpdesk, and they figured it as per the steps below.

The USB Serial connection to the TX16S Transmitter doesn’t work!

You have to use the WiWi connectivity (go into the ExpressLRS lua script, select WiFi Connectivity then enable WiFi and connect your PC to the SSID “ExpressLRS Tx”. Go to page

Use the ExpressLRS Configurator to build the update file for the Transmitter. Don’t use Build & Flash - it fails most of the time.

Set the Bind Phrase in the Configurator - on a new Tx, it’s set to something random.which prevents traditional binding or bind phrase working.

Go to the page and upload the file you’ve just built. It may take several goes!

If you get an error saying Bad Size or File too big, you need to download:

Repartitioner.bin from Releases · ExpressLRS/repartitioner · GitHub

Then upload that to the Tx. The Tx will reboot. Then the update will upload correctly without the error (but may take a few goes!).

Repeat the process for the Rx, making sure you use the same version of ExpressLRS (V3.0 in my case), other wise it won’t work.

Set the same bind phrase.

Power the Rx and cycle the power on the Tx and it should just connect!

To make the flight controller talk to it’s built-in Receiver, you have to connect

ERx to Tx2 and ETx to Rx2 (for iNAV)


ERx to Tx1 and ETx to Rx1 (for Ardupilot)

Using the jumpers supplied.

That’s taken about 40 hours to figure out. I wish someone else had posted instructions like this somewhere on line but there’s nothing!