APM 2.6 Tricopter tail servo


#1

Could somebody please take the time to give me some advice?
I need some advice to get my beast off the ground.

I have been working and learning this stuff for 2 years now, and it is time to get a project off the ground.

I have done everything to get my tail/tilt servo working, or at least I think I have…

Let me explain what I have done…

I’m running a APM 2.6 W external compass.
The rear rail is powered from the balance plug off a 14v 4s, through a filtered step down converter at 6V

The tail servo is plugged into #7 as per the instructions, but no movement after before, or after arming. The props do spin up when throttle is applied.
From what I understand the tail servo should move, after arming. It has power, and the metal geared servo is not
faulty.

I say this because once I powered the rail properly, the tail servo “straightened out” after the rail was powered correctly, and of course I ran a multi meter on all center power pins, to check for proper voltage to the servo outputs.

Now, I used to get a check board voltage warning in MP, but after troubleshooting all possibilities I found that it was a faulty USB cable. The warning is now gone, after a new cable is being used. APM 2.6 is not faulty.

I read on another forum that a guy was getting the same issue, but after disabling the pre arm check his tail servo worked for him. I have not disabled pre arm, to try this Yet…

Now the questions…

Is there something in advanced parameters I should be looking at?

I went in there and looked at RC_7, and it is enabled, but everything else is a mystery at the moment.

Should I use another servo output?

Is it a setting on my TX? (Futaba 9C)

Where do I start to trouble shoot this thing?

Does anybody have a list of things I could check to make it work? Frustrated…

Thanks,
Ted


#2

By the sounds of it your servo is working properly but just to double check I would suggest you plug it directly into your receiver and see if the servo itself is working.

Assuming that it is the next thing would be to check if you have power on your APM output rail, you will need a multi-meter for this. Or you could check by moving the servo off center when everything it powered off, and when you turn the power back on it should move back to the neutral position. If that works then the problem is most likely a setting somewhere on your ardupilot board.

If that is the case then my suggestion would be to have your copter plugged into the mission planner when trying to arm it and you should see if it fails any of the pre-arm checks on the HUD.

If you dont see that your tricopter is arming then its probably an issue with your radio signals not being picked up by your APM, so I suggest starting at the beginning and going through the entire setup wizard again including the radio calibration and compass calibration.

Hope that helps


#3

Hello,
Thank you for replying…

Yes, the rail is powered via the balance plug, through a filtered step down converter at 6V

Yes, the servo does center, when everything is plugged in, plus I just pulled the servo wires off the #7 pins, plugged a new servo in , and no go. I also tested the installed servo, with a servo tester, and it works no problem.

No, there are no prearm warnings. I used to get a check board voltage, but I replaced the USB cable, and it is now gone.

I suspect it is in the PWM settings somewhere in advanced parameters, but I do not know where to start.

I do not suspect it is in the TX as I have done everything in my TX settings to get it to work, but I may have missed something.

I am running a FRSKY 2.4 TX module, along with a FRSKY D4R II RECIEVER in CPPM mode.
The throttle does spin up all 3 motors, so #1, #2, and #4 pins on the APM are functioning after arming.

I am sure it is just a setting, but it is driving me crazy, and giving my wife fuel to keep saying this is all a money pit… LOL