2 Axis Brushless Gimbal Controller v2 Problems


#1

Hi,
I bought the gimbal controller, wired up the battery and connected the motors. I have literally hit a brick wall with connecting to the controller and uploading the correct firmware. I have followed other instructions around on this forum and still no joy.

I am using the silabs driver to connect. I have tried all of the GUI programs and tried using the arduino program to upload firmware…HELP?

Thanks


#2

When you connect the board via USB, do you see any LED lights on the board? Could you please share a photo of your setup and also let me know what battery you are using to power the board?

Please be careful not to connect the board via USB only when the motors are connected as this could damage the board.

If you purchased the 2 axis gimbal controller board from us, then you will need to use the open source firmware/GUI which can be downloaded here

Although the board comes with firmware, it will be best if you try to upload the latest version again, for detail on how to upload the firmware with arduino please see the brushless gimbal (open source) help post

Hope that helps