Omnibus F4 V5 Flight Controller Guide

Yes I did, I put smartport in betaflight and I switched on telemetry and save everything , when I try to discover new sensors in the taranis, it only appears 4 sensors… Anyone around that has telemetry set up for wizard x220s that could help?

That sounds like it is working as I don’t expect too much data from the omnibus on the wizard as it is not packed with sensors. Which 4 do you see?

I managed to get it working finally, after using the uninverted Smart port signal from a tiny solder pad on the RX.
Still one UART short, so smart audio for VTX went to soft serial on motor 5 pin.

1 Like

I suspect Omnibus doesn’t allow inversion on soft serial, and that’s why soft serial worked for other peripherals but not inverted RX.
Soldering a wire from RX with uninverted signal was the only solution for me.

1 Like

Any chance you could add ezUHF RSSI to this guide?

A post was split to a new topic: Omnibus Problem

I am having a problem getting my satellite receiver communicating with my omnibus f4 pro v2 with Inav loaded, I am new to this, so not sure if I configured everything, but configured the ports tab and configuration reciever tab. Still it never goes into bind mode. It is getting power though

4 posts were split to a new topic: Omnibus F4 V5.1 Telemetry and Gps?

Awesome guide has helped me so much.

I am using RX1 TX1 for GPS and RX3 and TX3 for SCA and SCL Magnetometer Compass.

Can you advise which pad(s) I can use with softserial for Smartaudio on my TBS Unify Pro as I have used all the standart UART’s?

Many thanks

You could use the LED_Stip connector on J9 and enable softserial on that pin

Many thanks I will try that.

Thanks for all the information on here, I just have one issue using the Typhoon V2 4-1 ESC and Omnibus F4 V5. The current is only displaying 0.3-2 amp even at full power. I have selected J16 middle and bottom jumper.

Lowered the current scale in beta flight not helped seems as it’s the range of current not displaying.

Is the current sensor setup different as I heard it’s digital ?

I think we have been helping you over about this, but once we work it out I will update this post to help anyone else out who might have a similar issue.

Possible reasons:

  • ESC not connected correctly
  • battery leads not connected to current sensor correctly
  • current sensor not calibrated (you already said that you tried this so just adding here for someone else)
  • something else I can’t think of right now…

Hey Alex,

After flashing betaflight 3.3 the problem is still here so I decided to use ESC telemetry instead of the inbuilt current sensor on the ESC. This is working now and showing a full range of amps. I don’t know but is there something that needs changing on the Typhoon V2 4-1 ESC to output current instead of ESC telemetry?

Just one more problem do you know how to adjust the calibration of ESC current in betaflight as the adjustment does not show on the configuration page on betaflight when in ESC telemetry mode?


As far as I recall you don’t need to change anything on the typhoon ESC to enable.regular current output… but I will check with the designer…

To calibrate the individual esc current sensors you will need to do this within the blheli32 suite (you can connect via passthrough). I read in December 2017 that the Devs will be adding this feature to blheli32 but not sure if it has been added yet.

Hi Alex, me again! It would be most helpful to have the location of the UART’s marked on the pin out guide. UART 6 is but none of the others are. Also, can you explain how and where to connect a bluetooth transceiver to the v5 board.

2 posts were split to a new topic: Beginner FPV Questions


I have the same FC but dont seem to be able to get my crossfire working on J6 TX6 & RX6. I am using TX1 and RX1 for GPS and TX3 and RX3 for my compass so was hoping to use J6.

I was also wondering about the inversion issue.

Any ideas?

Best wishes


i have the Omnibus F4 V5.1 and the Typhoon32 V1.2 connected with the 8-pin-cable.
As rx i use a Spektrum-Sat on UART1. On J16 i have bridged the lower and the middle pin to see the current from the Typhoon.
But nothing displays, when i switched in “Power&Battery” to "ESC Sensor.
With “Onboard ADC” it shows 48 Amperes when the motors still stand.
Has anyone an idea what i can do to show the current from the Typhoon ?.
Sorry for my bad school-english, it was 40 years ago ;).

Have you gone through the current sensor calibration? There are a few ways to do this, but the safest way to get a good estimate is shown in this video: (the beginning of it is just talking, information starts at around 2:25.

Otherwise another way to do this is to measure the value of the resistor next to the actual current sensor resistor on your FC and then you can calculate what the scale/offset should be as discussed in this RCG post

There is also a third way to attach a Watt meter to your quad and measure the current when motors are running and then adjust the current, but you need to be careful when doing this as it can be quite dangerous since you are throttling up your motors with propellers while its resting on your desk!.