FuriousFPV Kombini no UART1 data


#1

Hi All
New to this forum
I have tried to contact unmannedtech but no reply.

My problem

I have a kombini fc on betaflight, I’m trying to get uart1 to send data to micro minim osd, all settins are correct, even been on GitHub to have my setting checked, one of the guys on there said it looks all ok to him and probably a faulty board.
Anybody else had any problems with kombini board?
Mine is flashed woth betaflight pikoblx 3.0.1
I cant access the osd gui but quad is flyable but never flown, ive had a close inpection of the board x25 magnification all looks fine ie no damage, all connection check out fine.
Has me stumped??
I know I can get battery voltage to micro minim by soldering wires to the osd, but I wanted to use the osd feature to tune the pids, as it stands now I have to land, connect to pc and try again.

Has anybody had similar problems or suggest anything??

Cheers

Jeff


#2

I think the problem is due to the fact that you flashed it with piko target as the firmware.

​Please download the kombini target and reflash it to the board and it should work fine then - https://github.com/NightHawk32/cleanflight/releases


#3

Thanks for that will give it a go later and let you know what happens.
Any idea why these boards are being supplied with pikoblx if it doesn’t work
I have another quad flashes with pikoblx 3.0.1 and it works fine.
Seems odd that identical boards with same firmware and 1 works and the ither doesn’t, are they being cloned already, not saying I have a cloned board, just don’t know


#4

Hi

I have reflashed with betaflight 3.1.0 hex and still no out put to osd, I think this is a faulty board and needs to be replaced.

regards

jeff


#5

hi

I assume its the kombini hex I need and not the pikoblx hex

jeff