FTDI Basic Problems


#1

I recently purchased an FTDI Basic from your site see link

http://www.unmannedtechshop.co.uk/ftdi-basic-5v/

to load the firmware onto a mini micro OSD. However I’ve not been able to find any drivers for the USB to serial comms device on the board, I’ve tried the FTDI drivers without success. Also the silk screen is different to the one displayed on your website the TX and RX pins are reversed.

Can you please advice if the TX and RX pins are as labelled by the silk screen and were can I download the correct windows drivers?

Thanks.


#2

When did you place an order with us as it seems that is one of our older FTDI boards? You should be able to download the drivers from the FTDI website

As for the board not working, does any LED light up when you plug it in? Otherwise it could just be that the one you got is faulty in which case we will replace it for you, just send an email to support for a replacement.


#3

I placed the order about 1 week ago, I’ve emailed support with my order number. I’ve already tried the FTDI drivers.

When I plug it in none of the LEDS light.


#4

Alright definitely sounds like the board you have is a dud :frowning: will check the email and send out a replacement to you today.


#5

Thank you and the new boards work with the FTDI drivers?


#6

Yeah they should, the fact that you dont see any LED when you plug in the board means the one you have is faulty so I believe that was the problem with the drivers not working.


#7

Did my email arrive in your support inbox ok?