Faulty Item - Uavionix SkyEcho 2 Portable ADS-B Transceiver Not Charging

Order Number: #S00136-WH/OUT/14098)
Product Name: Uavionix Skyecho 2 Portable Ads-B Transceiver
Brand: NOt sure
Item does not power up nor activate
I have not done anything physical to the device, it was unboxed for 1st time over weekend.

Hi, sorry to hear about the issue, it looks like it may be a battery issue so I will send a request over to the manufacturer (Uavionix) to see if they are able to help further with any warranty repairs/replacement. The item was ordered over a year ago, so I assume it has been working fine in this time and only recently developed this issue?

Can I also ask the obvious question, that when you try to charge the unit, or power it externally, does it then turn on and function correctly?

Good morning,

It was only taken out of its box over the weekend as per returns email, it hasnt been used.

The operator had followed the instructions and was unable to get it to power on,



Thank you for providing some extra info.

Can I ask if you have tried to charge the module (sorry if its a very obvious question but I have to check). Otherwise i have send a request to Uavionix who should be able to offer some furhter insigts into this issue. I will update you once I head back from them.

Good afternoon,

Yes we have, we opened it for the first time on the weekend, powered it up some lights showed and now nothing lights up on the device.


Just to update you, we are talking with Uavionix support team and will get back to you as soon as we have a resolution from them.

Hi, just to update you we have spoken with the manufacturer now, and they seem to think its the charger that is causing the fault.

From Uavionix:

It is important to charge your Sky Echo with a charger that meets the QC3 standard (Output of 3A). A USB port on a computer CANNOT adequately charge a Sky Echo nor can a standard phone charger of less than at least 2.4 Amps. If you have a non USB-C iPad you can use the charger from that as recent models charge at 2.4A (though older models are only 2A).

We recommend this Anker 18W/3A/QC3 charger which you can purchase from Amazon:


Do not use a USB-C to USB-C charger/cable combination – you need to use a USB-A to USB-C charger/cable combination. We have provided a suitable USB-A to USB-C cable.

The issue you report should be solved when you connect to a suitable charger.

Please let me know some specifics on the charger you are using if its similar specs to the one linked above and I can provide some more feedback to them if this doesn’t solve the issue!


The best thing to do is to send this unit back for repair/replacement,

An RMA (Return Merchandise Authorization) has been created for your order.

You should receive an email shortly at the address associated with your order. This email will contain:

Instructions for completing the return process

Please check your inbox (and spam folder) for this email. If you don’t receive it within the next hour, please let us know here.

Remember to complete the RMA form and initiate your return within 30 days. If you have any questions, feel free to ask them in this thread