CrazyBee F4 Pro V2.0 will not ARM

wonder if some one can suggest a bit of advice. I have a Crazybee F4 2.0 pro with Spektrum on board. the first problem is when i use the CLI and enter either set spektrum_sat_bind=9 or 5, I tried both and both make the board go into bind mode, then bind it, it will bind. I can even set the bind and take it off Betaflight , then plug battery, it flashes and I can bind with the Radio. But if i unplug the Battery, or USB and plug it in again it does not go into bind until i put it thorugh betaflight and repeat the process above. I can’t keep it to stay in the bind mode. I have to repeat the process through betaflight to get it to go into bind mode.

The 2nd problem is after I get a bind it will not arm. I have gone through all the suggestions i could find in the blogs and such and it will not arm. Radio is working and Betaflight is showing the movement of my sticks and switches. and the FC is going into bind mode once, i bind it via the Spektrum bind button. Switch my ARM switch and nothing. It will not ARM. Also in betaflight the ARM mode never goes yellow. I have all my settings 1000-2000 and the mode shows it in the range but it never goes yellow. When I unplug the battery, from the FC and then plug the battery back in, the FC is no longer going into bind mode (flashing). I have to get the FC back in betefight “set spektrum_sat_bind=9” then i can repeat the bind process once.

One test I did was to bind it on the usb. THen goto the motors in betaflight and enable them. I could then spin the motors up and down with the radio. I unplugged it from the betaflight and could get it into the air BUT the rolls were reversed. I brought the quad down and unplugged the battery and of course lost the bind and was in the same boat as the start. My travel on my radio is all correct as far as i can tell. the CLI does not report any errors , other then the normal ones you get about it being on betaflight and such. when i enable my arm switch i can see betaflght showing they are there but the ARM never goes yellow. I have set all my travel on betaflight between 1000 and 2000 and the throttle min is set to 1050 so i know it is not my throttle so high to arm. Man, i am exasperated with this. I really want to get this going. Oh and one thing. The board shipped with betaflight_4.0.0_CRAZYBEEF4DX_20181211.hex and that would not allow any of the modes in betaflight to be displayed so i flashed with the latest version of beta fight for the FC. I even put the original version back on it and checked it and nothing. Currently i have Betaflight / CRAZYBEEF4DX (C4DX) 4.0.6 Sep 1 2019 / 00:26:33 (2a64051a2) MSP API: 1.41 on it.

Solved! I answered my own question. This site has all the info for setup. It was simply my radio, and the fact that the switch i normally use for arming is tied to gear. I really never had this problem before but for some reason it is now. As for the not staying in bind mode is seems you need to CLI this command: set spektrum_sat_bind_autoreset=off, if you want it to go into bind mode each time you plug in the battery. if you dont like that the set it to “on” after you bind the first time

Great to hear that!
If you have other Problems/Questions, feel free to let us know :wink:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.