Brand New Sailfly x - Not taking off, motor flip out

Hi all, appreciate any assistance on the new Sailfly x I purchased

  • Updated firmware due to Sailfly x known issue with old firmware & betaflight motor tab (doesn’t load, crashes)
  • Followed Happymodel instructions (attached image) to resource motors
  • When testing motors in betaflight, all run smoothly.
  • When plugging battery in outside of betaflight, and binding taranis x-lite in D8 (had same issue on D16), once armed (& throttle still down), the quad shakes to start and sort of ‘tugs’ for 1 - 2 seconds, then the motors turn off. Every once in awhile this happens for over 3-4 seconds, however clearly this causes the quad to flip over or just shake and turn off with the props on
  • Issue happens the same in angle mode or not

I’ve checked so far:

  • Running each motor in betaflight to confirm spinning correct direction, and powering all with master switch and power is even
  • Checked the props are on correctly in right positions
  • Checked in CLI that the resource command worked correctly
  • Checked calibration on the quad and reset
  • Checked in betaflight that the receiver is correctly working (throttle to throttle) TAER1234 on both betaflight and taranis x-lite is set
  • Checked taranis x-lite to work fine with a separate quad (tinyhawk s)

I am mainly following this:

Video:

Pics:

Thank you,
Elliot

if thats your quad in the bottom pic and you have set up following that paper, for a start your props are on backwards.
if you have set motor stop there is no way they should spin when armed so i suspect the firmware is a little suspect.
did you ever fly or just update the firmware when you recived it.

just looked at vid and defo looking at the motor spin your props on wrong. sort that out first. also with props removed does the qwad follow the pic when moving in the startup screen in BF.
as fwd = fwd and so on.

deleted as no longer relevant

@dale589 previously the quad followed the 3D model in BF most of the time. However I noticed in the past that the Yaw was reversed when moving the quad. I had re-calibrated a few times, and sometimes that fixed the issue.
Now when opening in BF there is definitely a matching issue with the 3D model. Sometimes the roll is reversed, sometimes the Yaw is reversed.
Otherwise I figured in Angle mode, that the accelerometer wouldn’t matter.

Also I never flew the quad before updating the firmware, because one of the tabs in betaflight literally cannot open with stock Sailfly x as happymodel made some mistake.

Thank you

Hi this is now solved, it was purely a firmware & BF issue.
I did not use the manufacturers updated ‘Diff’ CLI command & matching correct board firmware version:

Once I followed the steps in this video, the problem was solved…

Thanks again @dale589 for your prompt help!