Matek F722 + Betaflight


OMG I just had a intense moment with this Matek fc :smile: :blush:
I was thinking of trying both lipo and usb but before that I had a random thought of trying another usb cable laying around (it’s a fast charging cable) and it made the usb connection sound in windows.
I tried 2 cables but may be they are not speed enough? idk
It works fine now. Thanks for the help everyone. Then I pluged the default cable and it don’t work. idk why it didn’t work with the other usb cable I tried.

I just flashed the recent firmware and feels gooooood :smiley:


there are two types of usb cables…
power and data

you may have been using a power cable they look the same.

well done in finding your problem and moving forwards


Does anyone know what does led and buzzer port mean in matek f722? is it a power port or a signal port that can be controlled using radio? Like a servo?


talking about the bottom left six holes now, the G 5v and LED on top are for programmable RGB led lights, eg blue disarm red arm, needs to be turned on in config then programmed through led tab.
painless 360 as a good instruction video here
Bottom row S3 is for motor 3 signal 5v and buz are to attach a pietzo buzzer that sounds when aircraft lost, low battery etc can be switch on off from radio by switch but must config in modes tab.


Show DFU when writing?


It says there is 8 motor support but i only see 7 which including the pwm pad. Anyone know where is the motor 8? How do I actually find out what ports are those codes for example, A02, B02, A00, A01…
Help please

Resourse list is:

resource BEEPER 1 C13
resource MOTOR 1 C06
resource MOTOR 2 C07
resource MOTOR 3 C08
resource MOTOR 4 C09
resource MOTOR 5 B01
resource MOTOR 6 A08
resource MOTOR 7 B08
resource MOTOR 8 A02
resource PPM 1 A03
resource PWM 1 A00
resource PWM 2 A01
resource LED_STRIP 1 A15
resource SERIAL_TX 1 A09
resource SERIAL_TX 2 A02
resource SERIAL_TX 3 C10
resource SERIAL_TX 4 A00
resource SERIAL_TX 5 C12
resource SERIAL_RX 1 A10
resource SERIAL_RX 2 A03
resource SERIAL_RX 3 C11
resource SERIAL_RX 4 A01
resource SERIAL_RX 5 D02
resource I2C_SCL 1 B06
resource I2C_SDA 1 B07
resource LED 1 B09
resource LED 2 A14
resource SPI_SCK 1 A05
resource SPI_SCK 2 B13
resource SPI_SCK 3 B03
resource SPI_MISO 1 A06
resource SPI_MISO 2 B14
resource SPI_MISO 3 B04
resource SPI_MOSI 1 A07
resource SPI_MOSI 2 B15
resource SPI_MOSI 3 B05
resource ADC_BATT 1 C00
resource ADC_RSSI 1 B00
resource ADC_CURR 1 C04
resource SDCARD_CS 1 C01
resource OSD_CS 1 B10
resource SPI_PREINIT_IPU 1 C02
resource SPI_PREINIT_IPU 2 C01
resource SPI_PREINIT_IPU 3 B10


you will notice A02 motor 8 is also serial tx2. these are resources the board uses as outputs and inputs.
it is possible to reassign any resource to most pads.
you seam to have a few problems with FC and firmware so being honest i would suggest you leave alone.
you cannot damage it, if you mess it up all that is required is a re-flash and all back to normal.
if you have an old FC practice moving motor outputs to different pads, this is very useful if after a crash a pad gets pulled of.


Hello Brother.
How did you install a pin on the control board?


I bought the pin headders from banggood. just put some in holes and solder from back side.


Hello, I am having Similar issue here.

I have the same Mateks f722 FC with the FC-Hub for PDB, and it connects to betaflight with out a problem with the micro usb on my computer for configuring it. But when i try to flash the firmware, it would not connect. It throws “Failed to open serial port” error. I tried changing the wire’s and different usb configuring softwares but still no change.

Also when i am in config mode with betaflight, it states that there are 3 I2C error at the bottom of the page. Could that be related to this issue?

Thank you,


To flash the FC you need to put in into DFU mode…

Unplug the USB cable.
Hold the Boot button.
Then plug back in the USB cabe.

Betaflight configuration should show DFU in the top left corner.
If not while its still plugged in.
Download and Run
ImpluseRC Driver Fixer tool.


Thank you! That helped me get tp DFU mode successfully.
But then I run in to another problem again.

After choosing my board and the latest release of betaflight, I loaded the firmware and connected my board in DFU mode. When I clicked “flash firmware” nothing happened interms of flashing the board. Instead recieved this message:

2019-01-05 @ 05:04:22 – Using cached release information for configurator releases.

2019-01-05 @ 05:04:29 – Using cached builds information for jobs.

2019-01-05 @ 05:04:29 – Using cached release information for firmware releases.

2019-01-05 @ 05:04:30 – Using cached release information for firmware releases.

2019-01-05 @ 05:05:15 – USB device successfully opened with ID: 1

2019-01-05 @ 05:05:15 – USB device successfully closed

2019-01-05 @ 05:05:19 – USB device successfully opened with ID: 2

2019-01-05 @ 05:05:19 – USB device successfully closed

When I checked the firmware on my FC, it is still the old one 3.2.0.
Here is what my BF config look like:


Did you click “no reboot sequence” and “full chip erase”


Looking at you screenshot

It looks like you have loaded the firmware but not flashed the firmware.

Also do as @blackhole says and select those two options


Yes I did load the firm ware and also selected flashware.
I have also tried selecting “no reboot sequence” and “full chiip erase”.

After I load the firmware and click the flash firmware button, it wouldn’t flash the board. and the upload status bar doesn’t show it uploading or anything. I recieved this codes:
2019-01-05 @ 05:04:30 – Using cached release information for firmware releases.
2019-01-05 @ 05:05:15 – USB device successfully opened with ID: 1
2019-01-05 @ 05:05:15 – USB device successfully closed

Also, when it is in DFU mode I see one bright red light and one faint red light near the button just like @blackhole did on this pic.


more information on what i am getting from the board:

  • when i connect betaflight in configuration mode, I see that I have 3 I2C errors that I can not figure out what caused them or how to get rid of those errors. (i don’t have anything connected to the SDA/SCL pins)

  • and is the “serial link status” bar on the top of BF interface, right under battery status bar, supposed to flash at a random rate or is it supposed to be ON uninterruptedly? because mine blinks.

Thank you for all your help!


Try flashing couple of older versions… I would say try another set of different usb cables.


I have tried that as well.
I used multiple mini usb cables that i use to transfer data from my android, but i received the same result.

I just tried flashing it with clean flight as well but i got the same thing as BF.

I am starting to think there is something wrong with the FC!

@blackhole do you have any I2C error on your board when you configure it with BF?


@ntsami Im not with my drone so cant check for at least a week. The usb I checked was a samsung usb cable which can transfer phone data across but didn’t work for the flight controller. Keep trying usb cables…



Enter this in CLI if you have Matek F722-STD :
set baro_hardware = BMP280

It should fix some I2C errors